summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-11-22 21:43:27 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-11-22 21:43:27 +0000
commit38650dd2c181872d911ba751a2a5fcf7fc2ecd33 (patch)
tree6b9b96c8c601ab4401f1a5137e71f0e7dc95910a /dev-python/python-ptrace
parentAdd myself as maintainer. (diff)
downloadgentoo-2-38650dd2c181872d911ba751a2a5fcf7fc2ecd33.tar.gz
gentoo-2-38650dd2c181872d911ba751a2a5fcf7fc2ecd33.tar.bz2
gentoo-2-38650dd2c181872d911ba751a2a5fcf7fc2ecd33.zip
Reverted the revbump and applied changes to 0.6.3
(Portage version: 2.2.0_alpha46/cvs/Linux i686)
Diffstat (limited to 'dev-python/python-ptrace')
-rw-r--r--dev-python/python-ptrace/ChangeLog6
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.6.3-r1.ebuild45
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.6.3.ebuild13
3 files changed, 16 insertions, 48 deletions
diff --git a/dev-python/python-ptrace/ChangeLog b/dev-python/python-ptrace/ChangeLog
index 284b2f4cc569..a78c60727b11 100644
--- a/dev-python/python-ptrace/ChangeLog
+++ b/dev-python/python-ptrace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/python-ptrace
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.8 2011/11/22 21:02:59 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.9 2011/11/22 21:43:27 neurogeek Exp $
+
+ 22 Nov 2011; Jesus Rivero <neurogeek@gentoo.org>
+ python-ptrace-0.6.3.ebuild, -python-ptrace-0.6.3-r1.ebuild:
+ Reverted the revbump and applied changes to 0.6.3
*python-ptrace-0.6.3-r1 (22 Nov 2011)
diff --git a/dev-python/python-ptrace/python-ptrace-0.6.3-r1.ebuild b/dev-python/python-ptrace/python-ptrace-0.6.3-r1.ebuild
deleted file mode 100644
index a4f3d59e9a59..000000000000
--- a/dev-python/python-ptrace/python-ptrace-0.6.3-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.3-r1.ebuild,v 1.1 2011/11/22 21:02:59 neurogeek Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils
-
-DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)."
-HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ http://pypi.python.org/pypi/python-ptrace"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-DOCS="PKG-INFO"
-
-DEPEND=""
-RDEPEND="dev-libs/distorm64"
-RESTRICT_PYTHON_ABIS="2.4"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-PYTHON_MODNAME="ptrace"
-
-src_prepare() {
- python_copy_sources
-
- conversion() {
- [[ "${PYTHON_ABI}" == 2.* ]] && return
-
- 2to3-${PYTHON_ABI} -w . > /dev/null || die "2to3 failed"
- 2to3-${PYTHON_ABI} -dw . > /dev/null || die "2to3 failed"
- }
- python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
-}
-
-src_install() {
- distutils_src_install
- if use examples; then
- insinto usr/share/doc/${PF}/examples
- doins examples/*
- fi
-}
diff --git a/dev-python/python-ptrace/python-ptrace-0.6.3.ebuild b/dev-python/python-ptrace/python-ptrace-0.6.3.ebuild
index ae5e1c37657f..203302fe1d26 100644
--- a/dev-python/python-ptrace/python-ptrace-0.6.3.ebuild
+++ b/dev-python/python-ptrace/python-ptrace-0.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.3.ebuild,v 1.1 2011/07/28 20:19:22 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.3.ebuild,v 1.2 2011/11/22 21:43:27 neurogeek Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="examples"
DEPEND=""
RDEPEND="dev-libs/distorm64"
@@ -34,3 +34,12 @@ src_prepare() {
}
python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}