summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-15 17:32:46 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-15 17:32:46 +0000
commit0ead8bc85a2cdc91ad4e7d179338621a1666c08c (patch)
treeaea375b7bc816b21346f16305e7a3390c935ba89 /dev-python/python-ptrace
parentMask app-emacs/ngnus for removal, bug 293302. (diff)
downloadgentoo-2-0ead8bc85a2cdc91ad4e7d179338621a1666c08c.tar.gz
gentoo-2-0ead8bc85a2cdc91ad4e7d179338621a1666c08c.tar.bz2
gentoo-2-0ead8bc85a2cdc91ad4e7d179338621a1666c08c.zip
Version bump.
(Portage version: 14821-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-ptrace')
-rw-r--r--dev-python/python-ptrace/ChangeLog8
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.6.2.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/python-ptrace/ChangeLog b/dev-python/python-ptrace/ChangeLog
index 06d1f34785c8..55550c54b0ff 100644
--- a/dev-python/python-ptrace/ChangeLog
+++ b/dev-python/python-ptrace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-ptrace
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.4 2009/09/18 12:19:53 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.5 2009/11/15 17:32:46 arfrever Exp $
+
+*python-ptrace-0.6.2 (15 Nov 2009)
+
+ 15 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +python-ptrace-0.6.2.ebuild:
+ Version bump.
18 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
python-ptrace-0.6.ebuild:
diff --git a/dev-python/python-ptrace/python-ptrace-0.6.2.ebuild b/dev-python/python-ptrace/python-ptrace-0.6.2.ebuild
new file mode 100644
index 000000000000..9c6cb8bce4fc
--- /dev/null
+++ b/dev-python/python-ptrace/python-ptrace-0.6.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.2.ebuild,v 1.1 2009/11/15 17:32:46 arfrever Exp $
+
+EAPI="2"
+
+NEED_PYTHON="2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)."
+HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ http://pypi.python.org/pypi/python-ptrace"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-libs/distorm64"
+RESTRICT_PYTHON_ABIS="2.4"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+PYTHON_MODNAME="ptrace"
+
+src_prepare() {
+ python_copy_sources --no-link
+
+ conversion() {
+ [[ "${PYTHON_ABI}" == 2.* ]] && return
+
+ 2to3-${PYTHON_ABI} -w . > /dev/null || die "2to3 failed"
+ 2to3-${PYTHON_ABI} -dw . > /dev/null || die "2to3 failed"
+ epatch python3.0.patch
+ }
+ python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
+}