summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-01 14:26:29 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-01 14:26:29 +0000
commitaf572f2a90e7e3088b32b5ea0ca83cc082572c5f (patch)
treee0432867ab317133bdb6fcc40fbe18b2b023b959 /dev-python/python-iptables
parentVersion bump, security bug #525464. (diff)
downloadgentoo-2-af572f2a90e7e3088b32b5ea0ca83cc082572c5f.tar.gz
gentoo-2-af572f2a90e7e3088b32b5ea0ca83cc082572c5f.tar.bz2
gentoo-2-af572f2a90e7e3088b32b5ea0ca83cc082572c5f.zip
bump; add py3 support, keyword x86, IUSE doc and all that goes with a doc build, remove edundant patch, tidy, fixes Bug #526276, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-iptables')
-rw-r--r--dev-python/python-iptables/ChangeLog9
-rw-r--r--dev-python/python-iptables/python-iptables-0.3.0-r3.ebuild32
-rw-r--r--dev-python/python-iptables/python-iptables-0.3.0_p20130331.ebuild33
-rw-r--r--dev-python/python-iptables/python-iptables-0.5.0.ebuild42
4 files changed, 50 insertions, 66 deletions
diff --git a/dev-python/python-iptables/ChangeLog b/dev-python/python-iptables/ChangeLog
index 171b17bde74c..b1cc7a94920b 100644
--- a/dev-python/python-iptables/ChangeLog
+++ b/dev-python/python-iptables/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-iptables
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iptables/ChangeLog,v 1.9 2014/08/10 21:19:05 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iptables/ChangeLog,v 1.10 2014/11/01 14:26:29 idella4 Exp $
+
+*python-iptables-0.5.0 (01 Nov 2014)
+
+ 01 Nov 2014; Ian Delaney <idella4@gentoo.org> +python-iptables-0.5.0.ebuild,
+ -python-iptables-0.3.0-r3.ebuild, -python-iptables-0.3.0_p20130331.ebuild:
+ bump; add py3 support, keyword x86, IUSE doc and all that goes with a doc
+ build, remove edundant patch, tidy, fixes Bug #526276, rm old
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org>
python-iptables-0.3.0-r3.ebuild, python-iptables-0.3.0_p20130331.ebuild,
diff --git a/dev-python/python-iptables/python-iptables-0.3.0-r3.ebuild b/dev-python/python-iptables/python-iptables-0.3.0-r3.ebuild
deleted file mode 100644
index 53093e370038..000000000000
--- a/dev-python/python-iptables/python-iptables-0.3.0-r3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iptables/python-iptables-0.3.0-r3.ebuild,v 1.2 2014/08/10 21:19:05 slyfox Exp $
-
-EAPI=5
-PYTHON_COMPAT=(python2_7)
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for iptables"
-HOMEPAGE="https://github.com/ldx/python-iptables"
-SRC_URI="https://github.com/ldx/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="net-firewall/iptables"
-RDEPEND="${DEPEND}"
-
-# tests manipulate live iptables rules, so disable them by default
-RESTRICT=test
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.2.0-tests.patch"
- "${FILESDIR}/${P}-conntrack-fixes.patch"
- "${FILESDIR}/${PN}-fix-ctypes.patch"
-)
-
-python_test() {
- ${PYTHON} test.py || die "tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/python-iptables/python-iptables-0.3.0_p20130331.ebuild b/dev-python/python-iptables/python-iptables-0.3.0_p20130331.ebuild
deleted file mode 100644
index c41d83523566..000000000000
--- a/dev-python/python-iptables/python-iptables-0.3.0_p20130331.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iptables/python-iptables-0.3.0_p20130331.ebuild,v 1.2 2014/08/10 21:19:05 slyfox Exp $
-
-EAPI=5
-PYTHON_COMPAT=(python2_7)
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for iptables"
-HOMEPAGE="https://github.com/ldx/python-iptables"
-#SRC_URI="https://github.com/ldx/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI="mirror://gentoo/${P}.tar.xz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="net-firewall/iptables"
-RDEPEND="${DEPEND}"
-
-# tests manipulate live iptables rules, so disable them by default
-RESTRICT=test
-# needed for running tests
-#RESTRICT=userpriv
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.2.0-tests.patch"
-)
-
-python_test() {
- ${PYTHON} test.py || die "tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/python-iptables/python-iptables-0.5.0.ebuild b/dev-python/python-iptables/python-iptables-0.5.0.ebuild
new file mode 100644
index 000000000000..7ac8e76c7154
--- /dev/null
+++ b/dev-python/python-iptables/python-iptables-0.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iptables/python-iptables-0.5.0.ebuild,v 1.1 2014/11/01 14:26:29 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for iptables"
+HOMEPAGE="https://github.com/ldx/python-iptables"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="net-firewall/iptables
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+# tests manipulate live iptables rules, so disable them by default
+RESTRICT=test
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ ${PYTHON} test.py || die "tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}