summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-01-19 16:49:24 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-01-19 16:49:24 +0000
commit50280f0e52b72908347dba1bfe0fb1e6bc34db2a (patch)
tree5d70b68fde36cfcfb50c7dd5539bfa337fe36a77 /dev-python/pytables
parentVersion bump for cross-site request forgeries exploit reported in 301310 (diff)
downloadgentoo-2-50280f0e52b72908347dba1bfe0fb1e6bc34db2a.tar.gz
gentoo-2-50280f0e52b72908347dba1bfe0fb1e6bc34db2a.tar.bz2
gentoo-2-50280f0e52b72908347dba1bfe0fb1e6bc34db2a.zip
Now skip tests for numarray and numeric, obsoleted
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pytables')
-rw-r--r--dev-python/pytables/ChangeLog8
-rw-r--r--dev-python/pytables/files/pytables-2.1.2-no-old-num.patch38
-rw-r--r--dev-python/pytables/pytables-2.1.2.ebuild5
3 files changed, 47 insertions, 4 deletions
diff --git a/dev-python/pytables/ChangeLog b/dev-python/pytables/ChangeLog
index 485824e80b1f..dae5f7121914 100644
--- a/dev-python/pytables/ChangeLog
+++ b/dev-python/pytables/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pytables
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/ChangeLog,v 1.31 2009/12/12 16:26:37 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/ChangeLog,v 1.32 2010/01/19 16:49:23 bicatali Exp $
+
+ 19 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ pytables-2.1.2.ebuild, +files/pytables-2.1.2-no-old-num.patch:
+ Now skip tests for numarray and numeric, obsoleted
*pytables-2.1.2 (12 Dec 2009)
diff --git a/dev-python/pytables/files/pytables-2.1.2-no-old-num.patch b/dev-python/pytables/files/pytables-2.1.2-no-old-num.patch
new file mode 100644
index 000000000000..9e86effc2d29
--- /dev/null
+++ b/dev-python/pytables/files/pytables-2.1.2-no-old-num.patch
@@ -0,0 +1,38 @@
+--- tables/tests/test_all.py.orig 2010-01-19 17:12:43.000000000 +0000
++++ tables/tests/test_all.py 2010-01-19 17:13:23.000000000 +0000
+@@ -51,35 +51,6 @@
+ test_modules.append('tables.tests.test_indexvalues')
+ test_modules.append('tables.tests.test_index_backcompat')
+
+- # Add test_Numeric only if Numeric is installed
+- if common.numeric_imported:
+- import Numeric
+- print "Numeric (version %s) is present. Adding the Numeric test suite." % \
+- (Numeric.__version__)
+- if Numeric.__version__ < minimum_numeric_version:
+- print "*Warning*: Numeric version is lower than recommended: %s < %s" % \
+- (Numeric.__version__, minimum_numeric_version)
+- test_modules.append("tables.tests.test_Numeric")
+- else:
+- print "Skipping Numeric test suite."
+-
+- # Add test_numarray only if numarray is installed
+- if common.numarray_imported:
+- import numarray
+- print \
+-"""numarray (version %s) is present. Adding the numarray test suite.""" % \
+- (numarray.__version__)
+- if numarray.__version__ < minimum_numarray_version:
+- print \
+-"*Warning*: Numarray version is lower than recommended: %s < %s" % \
+- (numarray.__version__, minimum_numarray_version)
+- test_modules.append("tables.tests.test_numarray")
+- test_modules.append("tables.nra.tests.test_nestedrecords")
+- test_modules.append("tables.nra.tests.test_nriterators")
+- else:
+- print "Skipping numarray test suite."
+- print '-=' * 38
+-
+
+ # The test for garbage must be run *in the last place*.
+ # Else, it is not as useful.
diff --git a/dev-python/pytables/pytables-2.1.2.ebuild b/dev-python/pytables/pytables-2.1.2.ebuild
index 616c9cca8652..9f4084ca6d1c 100644
--- a/dev-python/pytables/pytables-2.1.2.ebuild
+++ b/dev-python/pytables/pytables-2.1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/pytables-2.1.2.ebuild,v 1.1 2009/12/12 16:26:37 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/pytables-2.1.2.ebuild,v 1.2 2010/01/19 16:49:23 bicatali Exp $
EAPI=2
inherit eutils distutils
@@ -27,6 +27,7 @@ DOCS="ANNOUNCE.txt MIGRATING_TO_2.x.txt RELEASE_NOTES.txt THANKS"
src_prepare() {
epatch "${FILESDIR}"/${P}-failingtests.patch
+ epatch "${FILESDIR}"/${P}-no-old-num.patch
}
src_test() {