summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2009-06-19 14:40:07 +0000
committerChristian Ruppert <idl0r@gentoo.org>2009-06-19 14:40:07 +0000
commit3c0a3c7a67480a5435846e0a5ac32e1741ab9daf (patch)
treed843f573943b004d5b4da88bec03a4e3735031df /dev-python/pylint
parentNon-maintainer commit: Version bump, security bugs 263711 and 266438, bump re... (diff)
downloadgentoo-2-3c0a3c7a67480a5435846e0a5ac32e1741ab9daf.tar.gz
gentoo-2-3c0a3c7a67480a5435846e0a5ac32e1741ab9daf.tar.bz2
gentoo-2-3c0a3c7a67480a5435846e0a5ac32e1741ab9daf.zip
Version bump to 0.18.0. Fix src_test. Cleanup.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/ChangeLog10
-rw-r--r--dev-python/pylint/metadata.xml27
-rw-r--r--dev-python/pylint/pylint-0.18.0.ebuild79
3 files changed, 102 insertions, 14 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index ca4348260f8e..d79d434b5678 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pylint
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.47 2009/03/26 21:13:08 jmbsvicetto Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.48 2009/06/19 14:40:07 idl0r Exp $
+
+*pylint-0.18.0 (19 Jun 2009)
+
+ 19 Jun 2009; Christian Ruppert <idl0r@gentoo.org> +pylint-0.18.0.ebuild,
+ metadata.xml:
+ Version bump to 0.18.0. Fix src_test. Cleanup.
26 Mar 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
metadata.xml:
diff --git a/dev-python/pylint/metadata.xml b/dev-python/pylint/metadata.xml
index dac5605e2070..6f7c605a3a69 100644
--- a/dev-python/pylint/metadata.xml
+++ b/dev-python/pylint/metadata.xml
@@ -1,18 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>python</herd>
- <longdescription lang="en">
- Pylint is a Python source code analyzer which looks for programming
- errors, helps enforcing a coding standard and sniffs for some code
- smells (as defined in Martin Fowler's Refactoring book).
+ <herd>python</herd>
+ <longdescription lang="en">
+ Pylint is a Python source code analyzer which looks for programming
+ errors, helps enforcing a coding standard and sniffs for some code
+ smells (as defined in Martin Fowler's Refactoring book).
- Pylint can be seen as another PyChecker since nearly all tests you can
- do with PyChecker can also be done with Pylint. However, Pylint offers
- some more features, like checking length of lines of code, checking if
- variable names are well-formed according to your coding standard, or
- checking if declared interfaces are truly implemented, and much more.
+ Pylint can be seen as another PyChecker since nearly all tests you can
+ do with PyChecker can also be done with Pylint. However, Pylint offers
+ some more features, like checking length of lines of code, checking if
+ variable names are well-formed according to your coding standard, or
+ checking if declared interfaces are truly implemented, and much more.
- Additionally, it is possible to write plugins to add your own checks.
- </longdescription>
+ Additionally, it is possible to write plugins to add your own checks.
+ </longdescription>
+ <use>
+ <flag name="html">Install HTML documenation</flag>
+ </use>
</pkgmetadata>
diff --git a/dev-python/pylint/pylint-0.18.0.ebuild b/dev-python/pylint/pylint-0.18.0.ebuild
new file mode 100644
index 000000000000..1e02ceda3bb1
--- /dev/null
+++ b/dev-python/pylint/pylint-0.18.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.18.0.ebuild,v 1.1 2009/06/19 14:40:07 idl0r Exp $
+
+EAPI="2"
+
+inherit eutils distutils python
+
+DESCRIPTION="a tool to check if a Python module satisfies a coding standard"
+HOMEPAGE="http://www.logilab.org/projects/pylint/"
+SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc examples html test tk"
+
+DEPEND=">=dev-python/logilab-common-0.38
+ >=dev-python/astng-0.19.0"
+RDEPEND="${DEPEND}
+ dev-lang/python[tk?]"
+
+src_test() {
+ python_version
+
+ local lpath="${T}/test/lib/python"
+ local tpath=""
+
+ # Create testdir and copy pylint into it for testing purpose.
+ mkdir -p "${lpath}/logilab" || die
+ PYTHONPATH="${lpath}" ${python} setup.py install --home="${T}/test" \
+ || die "test copy failed"
+
+ # To support test w/o setuptools.
+ if [[ -d "${lpath}/${PN}" ]]; then
+ tpath="${lpath}/${PN}"
+ else
+ tpath="${lpath}/${P}-py${PYVER}.egg/${PN}"
+ fi
+
+ # Copy pylint unittest and logilab-{common,astng} into our temporary test
+ # dir.
+ cp -r test/ ${tpath} || die "copy tests failed"
+ cp -r "$(python_get_sitedir)/logilab/"{common,astng} "${lpath}/logilab" \
+ || die "copying logilab-{common,astng} failed!"
+
+ pushd "${tpath}" >/dev/null || die
+ PYTHONPATH="${lpath}" pytest -v || die "tests failed"
+ popd >/dev/null || die
+}
+
+
+src_install() {
+ distutils_src_install
+
+ doman man/{pylint,pyreverse}.1 || die "doman failed"
+ dodoc doc/FAQ.txt || die "dodoc failed"
+
+ if use doc; then
+ dodoc doc/*.txt || die "dodoc failed"
+ fi
+
+ if use html; then
+ dohtml doc/*.html || die "dohtml failed"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "dodoc failed"
+ fi
+}
+
+pkg_postinst() {
+ if ! built_with_use dev-lang/python tk; then
+ ewarn "dev-lang/python has been built without tk support,"
+ ewarn "${PN}-gui doesn't work without Tkinter so if you really need it"
+ ewarn "re-install dev-lang/python with tk useflag enabled."
+ fi
+}