summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-07-23 22:39:08 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-07-23 22:39:08 +0000
commitc1ecbb1929d0a295b5f8ab60cb24b236e8e59b07 (patch)
tree3a24ba27961c160d689912513927ab80aecdf470 /dev-python/pygtkglext/pygtkglext-1.1.0.ebuild
parentMigrated to Generation 2. (diff)
downloadgentoo-2-c1ecbb1929d0a295b5f8ab60cb24b236e8e59b07.tar.gz
gentoo-2-c1ecbb1929d0a295b5f8ab60cb24b236e8e59b07.tar.bz2
gentoo-2-c1ecbb1929d0a295b5f8ab60cb24b236e8e59b07.zip
version bump (#141251)
(Portage version: 2.1-r1)
Diffstat (limited to 'dev-python/pygtkglext/pygtkglext-1.1.0.ebuild')
-rw-r--r--dev-python/pygtkglext/pygtkglext-1.1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pygtkglext/pygtkglext-1.1.0.ebuild b/dev-python/pygtkglext/pygtkglext-1.1.0.ebuild
new file mode 100644
index 000000000000..0c6d99d849ff
--- /dev/null
+++ b/dev-python/pygtkglext/pygtkglext-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkglext/pygtkglext-1.1.0.ebuild,v 1.1 2006/07/23 22:39:08 liquidx Exp $
+
+inherit python eutils
+
+DESCRIPTION="Python bindings to GtkGLExt"
+HOMEPAGE="http://gtkglext.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gtkglext/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/pygtk-2.8
+ >=dev-libs/glib-2.0
+ >=x11-libs/gtk+-2.0
+ >=x11-libs/gtkglext-1.0.0
+ dev-python/pyopengl
+ virtual/opengl
+ virtual/glu"
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README AUTHORS ChangeLog
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.py
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}