summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-07 09:54:33 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-07 09:54:33 +0000
commit85ec9daf64b7b679c935163d6fff28bafa9db0f6 (patch)
treea33252d674ed29cae28b1d332f836f69a59b9a12 /dev-python/pyenchant
parentMoved to EAPI=3 for PREFIX support, keyworded for *-linux, tested by me (diff)
downloadgentoo-2-85ec9daf64b7b679c935163d6fff28bafa9db0f6.tar.gz
gentoo-2-85ec9daf64b7b679c935163d6fff28bafa9db0f6.tar.bz2
gentoo-2-85ec9daf64b7b679c935163d6fff28bafa9db0f6.zip
Version bump.
(Portage version: 15754-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyenchant')
-rw-r--r--dev-python/pyenchant/ChangeLog8
-rw-r--r--dev-python/pyenchant/pyenchant-1.6.1.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/pyenchant/ChangeLog b/dev-python/pyenchant/ChangeLog
index e37e07c7fb2c..829c12469e23 100644
--- a/dev-python/pyenchant/ChangeLog
+++ b/dev-python/pyenchant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyenchant
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyenchant/ChangeLog,v 1.16 2010/03/04 16:26:10 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyenchant/ChangeLog,v 1.17 2010/03/07 09:54:33 arfrever Exp $
+
+*pyenchant-1.6.1 (07 Mar 2010)
+
+ 07 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pyenchant-1.6.1.ebuild:
+ Version bump.
*pyenchant-1.6.0 (04 Mar 2010)
diff --git a/dev-python/pyenchant/pyenchant-1.6.1.ebuild b/dev-python/pyenchant/pyenchant-1.6.1.ebuild
new file mode 100644
index 000000000000..9f7a4d3fea4e
--- /dev/null
+++ b/dev-python/pyenchant/pyenchant-1.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyenchant/pyenchant-1.6.1.ebuild,v 1.1 2010/03/07 09:54:33 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="Python wrapper for the Enchant spellchecking wrapper library"
+HOMEPAGE="http://pyenchant.sourceforge.net http://pypi.python.org/pypi/pyenchant"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=app-text/enchant-1.4.0
+ dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="enchant"
+DOCS="README.txt TODO.txt"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # TestInstallEnv tests are broken with Python 3 (enchant.tokenize is wrongly imported as tokenize).
+ sed -e "s/test_basic/_&/;s/test_UnicodeInstallPath/_&/" -i enchant/tests.py || die "sed failed"
+}