summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-05 02:54:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-05 02:54:41 +0000
commit4b7284b7e22592c3d2d2c77f47510dd5a6557b3d (patch)
treee92fb319c84b3aea1806af93e30ba961bf161e3c /dev-python/pycxx
parentfix building with gcc44 with patch from Fredric Johansson (bug #274001) (diff)
downloadgentoo-2-4b7284b7e22592c3d2d2c77f47510dd5a6557b3d.tar.gz
gentoo-2-4b7284b7e22592c3d2d2c77f47510dd5a6557b3d.tar.bz2
gentoo-2-4b7284b7e22592c3d2d2c77f47510dd5a6557b3d.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 13918-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/ChangeLog9
-rw-r--r--dev-python/pycxx/files/pycxx-6.1.0-C_compatible_headers.patch40
-rw-r--r--dev-python/pycxx/files/pycxx-6.1.0-python-3.patch13
-rw-r--r--dev-python/pycxx/files/pycxx-6.1.0-setup.py.patch35
-rw-r--r--dev-python/pycxx/pycxx-6.1.0.ebuild38
5 files changed, 134 insertions, 1 deletions
diff --git a/dev-python/pycxx/ChangeLog b/dev-python/pycxx/ChangeLog
index a0bf7d4325d3..e3573ded733a 100644
--- a/dev-python/pycxx/ChangeLog
+++ b/dev-python/pycxx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pycxx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/ChangeLog,v 1.2 2009/02/15 21:20:08 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/ChangeLog,v 1.3 2009/08/05 02:54:41 arfrever Exp $
+
+*pycxx-6.1.0 (05 Aug 2009)
+
+ 05 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pycxx-6.1.0.ebuild, +files/pycxx-6.1.0-C_compatible_headers.patch,
+ +files/pycxx-6.1.0-python-3.patch, +files/pycxx-6.1.0-setup.py.patch:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
*pycxx-5.5.0 (15 Feb 2009)
diff --git a/dev-python/pycxx/files/pycxx-6.1.0-C_compatible_headers.patch b/dev-python/pycxx/files/pycxx-6.1.0-C_compatible_headers.patch
new file mode 100644
index 000000000000..9ec64366e2c3
--- /dev/null
+++ b/dev-python/pycxx/files/pycxx-6.1.0-C_compatible_headers.patch
@@ -0,0 +1,40 @@
+--- CXX/WrapPython.h
++++ CXX/WrapPython.h
+@@ -1,3 +1,4 @@
++/*
+ //-----------------------------------------------------------------------------
+ //
+ // Copyright (c) 1998 - 2007, The Regents of the University of California
+@@ -34,27 +35,28 @@
+ // DAMAGE.
+ //
+ //-----------------------------------------------------------------------------
++*/
+
+ #ifndef __PyCXX_wrap_python_hxx__
+ #define __PyCXX_wrap_python_hxx__
+
+-// On some platforms we have to include time.h to get select defined
++/* On some platforms we have to include time.h to get select defined */
+ #if !defined(__WIN32__) && !defined(WIN32) && !defined(_WIN32) && !defined(_WIN64)
+ #include <sys/time.h>
+ #endif
+
+-// Prevent multiple conflicting definitions of swab from stdlib.h and unistd.h
++/* Prevent multiple conflicting definitions of swab from stdlib.h and unistd.h */
+ #if defined(__sun) || defined(sun)
+ #if defined(_XPG4)
+ #undef _XPG4
+ #endif
+ #endif
+
+-// Python.h will redefine these and generate warning in the process
++/* Python.h will redefine these and generate warning in the process */
+ #undef _XOPEN_SOURCE
+ #undef _POSIX_C_SOURCE
+
+-// pull in python definitions
++/* pull in python definitions */
+ #include <Python.h>
+
+ #endif
diff --git a/dev-python/pycxx/files/pycxx-6.1.0-python-3.patch b/dev-python/pycxx/files/pycxx-6.1.0-python-3.patch
new file mode 100644
index 000000000000..cc5ce2d8a79c
--- /dev/null
+++ b/dev-python/pycxx/files/pycxx-6.1.0-python-3.patch
@@ -0,0 +1,13 @@
+--- Lib/__init__.py
++++ Lib/__init__.py
+@@ -34,8 +34,8 @@
+ # DAMAGE.
+ #
+ #-----------------------------------------------------------------------------
+-print """CXX is installed.
++print("""CXX is installed.
+ The support files you need are in the PYTHON/etc/CXX directory.
+ The include files are in the distutils include path already.
+ Just refer to them as "CXX/CXX_Objects.h", etc.
+-"""
++""")
diff --git a/dev-python/pycxx/files/pycxx-6.1.0-setup.py.patch b/dev-python/pycxx/files/pycxx-6.1.0-setup.py.patch
new file mode 100644
index 000000000000..05b55dd56b0d
--- /dev/null
+++ b/dev-python/pycxx/files/pycxx-6.1.0-setup.py.patch
@@ -0,0 +1,35 @@
+--- setup.py
++++ setup.py
+@@ -3,22 +3,24 @@
+ from distutils.command.install import install
+ from distutils.core import setup
+
+-headers = (glob( os.path.join( "CXX","*.hxx" ) )
+- +glob( os.path.join( "CXX","*.h" ) ))
+-sources = (glob( os.path.join( "Src", "*.cxx" ) )
+- +glob( os.path.join( "Src", "*.c" ) ))
++headers = (glob( os.path.join( "CXX", "Python%s" % sys.version_info[0], "*.hxx" ) )
++ +glob( os.path.join( "CXX", "Python%s" % sys.version_info[0], "*.h" ) )
++ +[os.path.join( "CXX", "Version.hxx" )]
++ +[os.path.join( "CXX", "WrapPython.h" )])
++sources = (glob( os.path.join( "Src", "Python%s" % sys.version_info[0], "*.cxx" ) )
++ +glob( os.path.join( "Src", "Python%s" % sys.version_info[0], "*.c" ) ))
+
+
+ class my_install (install):
+
+ def finalize_options (self):
+- if not self.install_data or (len(self.install_data) < 8) :
+- self.install_data = "$base/share/python$py_version_short"
++ if not self.install_data or (len(self.install_data) < 8):
++ self.install_data = "$base/share/python$py_version_short"
+ install.finalize_options (self)
+
+ def run (self):
+- self.distribution.data_files = [("CXX", sources)]
+- self.distribution.headers = headers
++ self.distribution.data_files = [("CXX", sources)]
++ self.distribution.headers = headers
+ install.run (self)
+
+
diff --git a/dev-python/pycxx/pycxx-6.1.0.ebuild b/dev-python/pycxx/pycxx-6.1.0.ebuild
new file mode 100644
index 000000000000..dbfe86558203
--- /dev/null
+++ b/dev-python/pycxx/pycxx-6.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/pycxx-6.1.0.ebuild,v 1.1 2009/08/05 02:54:41 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils distutils
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+PYTHON_MODNAME="CXX"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-setup.py.patch"
+ epatch "${FILESDIR}/${P}-python-3.patch"
+ epatch "${FILESDIR}/${P}-C_compatible_headers.patch"
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dohtml -r Doc/ || die "dohtml failed"
+ fi
+
+ if use examples; then
+ docinto examples/python-2
+ dodoc Demo/Python2/* || die "dodoc failed"
+ docinto examples/python-3
+ dodoc Demo/Python3/* || die "dodoc failed"
+ fi
+}