summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-04 17:04:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-04 17:04:27 +0000
commit705f97d23054e6d473beda0b3ae8a79bb1eeeceb (patch)
tree7fa2d3c507c21fad9fb353aa2afb5fa06d43c446 /dev-python/pychart
parentStable on amd64 wrt bug #312727 (diff)
downloadgentoo-2-705f97d23054e6d473beda0b3ae8a79bb1eeeceb.tar.gz
gentoo-2-705f97d23054e6d473beda0b3ae8a79bb1eeeceb.tar.bz2
gentoo-2-705f97d23054e6d473beda0b3ae8a79bb1eeeceb.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pychart')
-rw-r--r--dev-python/pychart/ChangeLog8
-rw-r--r--dev-python/pychart/pychart-1.39.ebuild20
2 files changed, 20 insertions, 8 deletions
diff --git a/dev-python/pychart/ChangeLog b/dev-python/pychart/ChangeLog
index bf8c4fe43d97..0eca3327c439 100644
--- a/dev-python/pychart/ChangeLog
+++ b/dev-python/pychart/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pychart
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pychart/ChangeLog,v 1.13 2009/12/26 17:34:46 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pychart/ChangeLog,v 1.14 2010/04/04 17:04:27 arfrever Exp $
+
+ 04 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pychart-1.39.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
26 Dec 2009; Peter Volkov <pva@gentoo.org> pychart-1.37.ebuild,
pychart-1.39.ebuild:
diff --git a/dev-python/pychart/pychart-1.39.ebuild b/dev-python/pychart/pychart-1.39.ebuild
index 171357bd95ba..e796308823c1 100644
--- a/dev-python/pychart/pychart-1.39.ebuild
+++ b/dev-python/pychart/pychart-1.39.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pychart/pychart-1.39.ebuild,v 1.6 2009/12/26 17:34:46 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pychart/pychart-1.39.ebuild,v 1.7 2010/04/04 17:04:27 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -17,15 +21,19 @@ KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
IUSE="doc examples"
DEPEND="app-text/ghostscript-gpl"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
src_install() {
distutils_src_install
- if use doc ; then
- dohtml -r ${WORKDIR}/${PN}/*
+
+ if use doc; then
+ dohtml -r "${WORKDIR}/${PN}/"* || die "dohtml failed"
fi
- if use examples ; then
+
+ if use examples; then
insinto /usr/share/doc/${PF}/examples
doins demos/*
fi