summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-01-05 06:47:36 +0000
committerMike Gilbert <floppym@gentoo.org>2013-01-05 06:47:36 +0000
commit485691d199c905a4120dce28627df3390615aa26 (patch)
tree7889ce142226959a2529b75103a3223c3632969a /dev-python/pycairo
parentbump, requested by K. Niemi, Bug #447998 (diff)
downloadgentoo-2-485691d199c905a4120dce28627df3390615aa26.tar.gz
gentoo-2-485691d199c905a4120dce28627df3390615aa26.tar.bz2
gentoo-2-485691d199c905a4120dce28627df3390615aa26.zip
Annotate the WAF_BINARY setting thanks to Alexander Patrakov and cleanup src_test. Bug 447856.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/ChangeLog6
-rw-r--r--dev-python/pycairo/pycairo-1.10.0-r3.ebuild24
2 files changed, 12 insertions, 18 deletions
diff --git a/dev-python/pycairo/ChangeLog b/dev-python/pycairo/ChangeLog
index 5bf973f24330..e130972f4c1f 100644
--- a/dev-python/pycairo/ChangeLog
+++ b/dev-python/pycairo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pycairo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.123 2013/01/03 15:37:26 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.124 2013/01/05 06:47:36 floppym Exp $
+
+ 05 Jan 2013; Mike Gilbert <floppym@gentoo.org> pycairo-1.10.0-r3.ebuild:
+ Annotate the WAF_BINARY setting thanks to Alexander Patrakov and cleanup
+ src_test. Bug 447856.
04 Jan 2013; Ian Delaney <idella4@gentoo.org> pycairo-1.10.0-r3.ebuild:
Restricting pypy, its capacity to run the testsuite totally broken by the last
diff --git a/dev-python/pycairo/pycairo-1.10.0-r3.ebuild b/dev-python/pycairo/pycairo-1.10.0-r3.ebuild
index 97fc09b2b6c9..791c584ed305 100644
--- a/dev-python/pycairo/pycairo-1.10.0-r3.ebuild
+++ b/dev-python/pycairo/pycairo-1.10.0-r3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.10.0-r3.ebuild,v 1.12 2013/01/03 15:37:26 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.10.0-r3.ebuild,v 1.13 2013/01/05 06:47:36 floppym Exp $
EAPI="4"
PYTHON_DEPEND="2:2.6 3:3.1"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.0 *-jython 2.7-pypy-*"
+RESTRICT_PYTHON_ABIS="2.5 3.0 *-jython *-pypy-*"
inherit eutils python waf-utils
@@ -67,9 +67,13 @@ src_configure() {
export PYCAIRO_DISABLE_XPYB=1
fi
+ # Added by grobian:
# If WAF_BINARY is an absolute path, the configure is different and fails to
# find Python.h due to a compiler misconfiguration. If WAF_BINARY is just
# ./waf or python waf, it works fine. Hooray for reinvented buildsystems
+
+ # floppym:
+ # pycairo and py2cairo bundle different versions of waf (bug 447856)
WAF_BINARY="./waf"
python_execute_function -s waf-utils_src_configure --nopyc --nopyo
}
@@ -84,21 +88,7 @@ src_test() {
}
python_execute_function -q -s test_installation
- testing() {
- # Need a variable for the pypy minor version and a variable to set 2 distinct pythonpaths
- local pypy_v= PyPath= exit_status=0
- pypy_v=$(python_get_version)
- if [[ "${PYTHON_ABI:4:4}" == "pypy" ]]; then
- PyPath=$(find "${T}"/tests/2.7-pypy-$pypy_v/ -name site-packages)
- PYTHONPATH="${PyPath}" py.test-${PYTHON_ABI} "${WORKDIR}/${P}-${PYTHON_ABI}"/test || exit_status=1
- else
- PyPath="${T}/tests/${PYTHON_ABI}${EPREFIX}"$(python_get_sitedir)
- PYTHONPATH="${PyPath}" py.test "${WORKDIR}/${P}-${PYTHON_ABI}"/test || exit_status=1
- fi
-
- return $exit_status
- }
- python_execute_function testing
+ python_execute_py.test -P '${T}/tests/${PYTHON_ABI}${EPREFIX}$(python_get_sitedir)' -s
}
src_install() {