summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-13 13:27:21 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-13 13:27:21 +0000
commit1597df49df951b60d4f930bea8d18250b7f1412f (patch)
tree25bb1ab61804886bc21588552fb1a6c6823522ed /dev-python/py
parentRemove fperms. Bug #348553 (diff)
downloadgentoo-2-1597df49df951b60d4f930bea8d18250b7f1412f.tar.gz
gentoo-2-1597df49df951b60d4f930bea8d18250b7f1412f.tar.bz2
gentoo-2-1597df49df951b60d4f930bea8d18250b7f1412f.zip
Version bump.
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/py')
-rw-r--r--dev-python/py/ChangeLog8
-rw-r--r--dev-python/py/py-1.4.0.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/py/ChangeLog b/dev-python/py/ChangeLog
index b56e7178e589..d4ba099a474f 100644
--- a/dev-python/py/ChangeLog
+++ b/dev-python/py/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/py
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/py/ChangeLog,v 1.66 2010/10/23 18:17:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py/ChangeLog,v 1.67 2010/12/13 13:27:21 arfrever Exp $
+
+*py-1.4.0 (13 Dec 2010)
+
+ 13 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +py-1.4.0.ebuild:
+ Version bump.
23 Oct 2010; Raúl Porcel <armin76@gentoo.org> py-1.3.4.ebuild:
alpha/arm/ia64/sh/sparc stable wrt #341335
diff --git a/dev-python/py/py-1.4.0.ebuild b/dev-python/py/py-1.4.0.ebuild
new file mode 100644
index 000000000000..e5ab0e9ba7e4
--- /dev/null
+++ b/dev-python/py/py-1.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py/py-1.4.0.ebuild,v 1.1 2010/12/13 13:27:21 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="py.test"
+
+inherit distutils
+
+DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
+HOMEPAGE="http://pylib.org/ http://pypi.python.org/pypi/py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools
+ test? ( >=dev-python/pytest-2.0.0 )"
+RDEPEND=""
+
+DOCS="CHANGELOG README.txt"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable failing tests.
+ rm -f testing/path/test_svnauth.py
+ rm -f testing/path/test_svnurl.py
+ rm -f testing/path/test_svnwc.py
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog
+ elog "py.test script has been split to dev-python/pytest package."
+ elog "Other scripts have been split to dev-python/pycmd package."
+ elog
+}