summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-10-12 18:12:06 +0000
committerTim Harder <radhermit@gentoo.org>2014-10-12 18:12:06 +0000
commit41b7543bb3fc4e26e5a618b895cb97e5845ba8c6 (patch)
treeb2d4d15c15b0df55ea1e933f0845b18a357dc150 /dev-python/psutil
parentUpdate repo metadata. (diff)
downloadgentoo-2-41b7543bb3fc4e26e5a618b895cb97e5845ba8c6.tar.gz
gentoo-2-41b7543bb3fc4e26e5a618b895cb97e5845ba8c6.tar.bz2
gentoo-2-41b7543bb3fc4e26e5a618b895cb97e5845ba8c6.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/psutil')
-rw-r--r--dev-python/psutil/ChangeLog7
-rw-r--r--dev-python/psutil/psutil-2.1.3.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-python/psutil/ChangeLog b/dev-python/psutil/ChangeLog
index 09a82d68f722..1a9521512384 100644
--- a/dev-python/psutil/ChangeLog
+++ b/dev-python/psutil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/psutil
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/ChangeLog,v 1.39 2014/10/01 14:38:04 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/ChangeLog,v 1.40 2014/10/12 18:12:06 radhermit Exp $
+
+*psutil-2.1.3 (12 Oct 2014)
+
+ 12 Oct 2014; Tim Harder <radhermit@gentoo.org> +psutil-2.1.3.ebuild:
+ Version bump.
01 Oct 2014; Ian Delaney <idella4@gentoo.org> psutil-2.1.2.ebuild:
update HOMEPAGE, fixes bug #523424
diff --git a/dev-python/psutil/psutil-2.1.3.ebuild b/dev-python/psutil/psutil-2.1.3.ebuild
new file mode 100644
index 000000000000..9586380c658e
--- /dev/null
+++ b/dev-python/psutil/psutil-2.1.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/psutil-2.1.3.ebuild,v 1.1 2014/10/12 18:12:06 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Retrieve information on running processes and system utilization"
+HOMEPAGE="https://github.com/giampaolo/psutil https://pypi.python.org/pypi/psutil/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RESTRICT="test"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}