summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-09-27 17:23:17 +0000
committerMarien Zwart <marienz@gentoo.org>2006-09-27 17:23:17 +0000
commit463dc28e824442ae2f292a0dca447de7d8e1b107 (patch)
treea32e823b7ec45cf37dfb851548809b9d1d25eb59 /dev-python/pmw/pmw-0.8.5.ebuild
parentStable on alpha wrt bug #145524 (diff)
downloadgentoo-2-463dc28e824442ae2f292a0dca447de7d8e1b107.tar.gz
gentoo-2-463dc28e824442ae2f292a0dca447de7d8e1b107.tar.bz2
gentoo-2-463dc28e824442ae2f292a0dca447de7d8e1b107.zip
Clean up error message on missing Tkinter. Closes bug #149324, thanks to Gerolf Ziegenhain <derverstand@web.de> for reporting.
(Portage version: 2.1.2_pre1-r2)
Diffstat (limited to 'dev-python/pmw/pmw-0.8.5.ebuild')
-rw-r--r--dev-python/pmw/pmw-0.8.5.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/pmw/pmw-0.8.5.ebuild b/dev-python/pmw/pmw-0.8.5.ebuild
index fd17b1f9472a..f770c4cc03ec 100644
--- a/dev-python/pmw/pmw-0.8.5.ebuild
+++ b/dev-python/pmw/pmw-0.8.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-0.8.5.ebuild,v 1.17 2004/06/25 01:36:24 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-0.8.5.ebuild,v 1.18 2006/09/27 17:23:17 marienz Exp $
DESCRIPTION="A toolkit for building high-level compound widgets in Python using the Tkinter module."
HOMEPAGE="http://pmw.sourceforge.net/"
@@ -16,10 +16,7 @@ SRC_URI="mirror://sourceforge/pmw/Pmw.${PV}.tar.gz"
S="${WORKDIR}"/Pmw
src_compile() {
- if ! python -c "import Tkinter" >/dev/null 2>&1
- then
- die "You need to recompile Python with Tkinter support"
- fi
+ distutils_python_tkinter
python -c 'import compileall; compileall.compile_dir(".",force=1)'
}