summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-12-20 15:36:56 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-12-20 15:36:56 +0000
commitbb1a1c8c08fffe6d9d005c436e6044439fc5d848 (patch)
tree79c6afbfb29bc555e15bdc96ccbbb959caf0b158 /dev-python/platinfo
parentStable for AMD64, wrt bug #394393 (diff)
downloadgentoo-2-bb1a1c8c08fffe6d9d005c436e6044439fc5d848.tar.gz
gentoo-2-bb1a1c8c08fffe6d9d005c436e6044439fc5d848.tar.bz2
gentoo-2-bb1a1c8c08fffe6d9d005c436e6044439fc5d848.zip
dev-python/platinfo: Initial ebuild.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/platinfo')
-rw-r--r--dev-python/platinfo/ChangeLog10
-rw-r--r--dev-python/platinfo/metadata.xml25
-rw-r--r--dev-python/platinfo/platinfo-0.15.0.ebuild19
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/platinfo/ChangeLog b/dev-python/platinfo/ChangeLog
new file mode 100644
index 000000000000..7d04732966d2
--- /dev/null
+++ b/dev-python/platinfo/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/platinfo
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/platinfo/ChangeLog,v 1.1 2011/12/20 15:36:56 aidecoe Exp $
+
+*platinfo-0.15.0 (20 Dec 2011)
+
+ 20 Dec 2011; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ +platinfo-0.15.0.ebuild, +metadata.xml:
+ Initial ebuild.
+
diff --git a/dev-python/platinfo/metadata.xml b/dev-python/platinfo/metadata.xml
new file mode 100644
index 000000000000..4db3a662b0f4
--- /dev/null
+++ b/dev-python/platinfo/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a small Python module that determines and returns standardized
+ names for platforms, where the "standard" is Trent Mick's reasoning :)
+ from experience building ActivePython on a fairly large number of
+ platforms.
+
+ The driving goal is to provide platform names that are:
+ - relatively short
+ - readable (as much as possible making matching the given name to an
+ actually machine self-explanatory)
+ - be capable enough to produce all names needed to distinguish all
+ platform-specific application builds
+ - generally safe for usage in filenames
+ - not ugly (e.g. "MSWin32" is ugly)
+ </longdescription>
+</pkgmetadata>
+
diff --git a/dev-python/platinfo/platinfo-0.15.0.ebuild b/dev-python/platinfo/platinfo-0.15.0.ebuild
new file mode 100644
index 000000000000..02049f7dacf9
--- /dev/null
+++ b/dev-python/platinfo/platinfo-0.15.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/platinfo/platinfo-0.15.0.ebuild,v 1.1 2011/12/20 15:36:56 aidecoe Exp $
+
+EAPI=4
+
+inherit distutils
+
+DESCRIPTION="Determines and returns consistent names for platforms"
+HOMEPAGE="http://code.google.com/p/platinfo/"
+SRC_URI="http://platinfo.googlecode.com/files/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"