summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-19 15:01:15 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-19 15:01:15 +0000
commit3a0fcb3edcb0750f295e2cd247e1602b436f20f3 (patch)
treea366563be83de1e4c7cca0fc6efb27452bdf6597 /dev-python/pexpect
parentAdd pypy3 support (diff)
downloadgentoo-2-3a0fcb3edcb0750f295e2cd247e1602b436f20f3.tar.gz
gentoo-2-3a0fcb3edcb0750f295e2cd247e1602b436f20f3.tar.bz2
gentoo-2-3a0fcb3edcb0750f295e2cd247e1602b436f20f3.zip
Add pypy3 support
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pexpect')
-rw-r--r--dev-python/pexpect/ChangeLog5
-rw-r--r--dev-python/pexpect/pexpect-3.3.ebuild7
2 files changed, 7 insertions, 5 deletions
diff --git a/dev-python/pexpect/ChangeLog b/dev-python/pexpect/ChangeLog
index e70ba15d165d..78c1cd0f8241 100644
--- a/dev-python/pexpect/ChangeLog
+++ b/dev-python/pexpect/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pexpect
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pexpect/ChangeLog,v 1.84 2014/11/11 11:14:43 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pexpect/ChangeLog,v 1.85 2014/11/19 15:01:15 idella4 Exp $
+
+ 19 Nov 2014; Ian Delaney <idella4@gentoo.org> pexpect-3.3.ebuild:
+ Add pypy3 support
11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> pexpect-3.3.ebuild:
Stable for ia64, wrt bug #524416
diff --git a/dev-python/pexpect/pexpect-3.3.ebuild b/dev-python/pexpect/pexpect-3.3.ebuild
index 7affd256db66..98f76c6dcdd9 100644
--- a/dev-python/pexpect/pexpect-3.3.ebuild
+++ b/dev-python/pexpect/pexpect-3.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pexpect/pexpect-3.3.ebuild,v 1.10 2014/11/11 11:14:43 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pexpect/pexpect-3.3.ebuild,v 1.11 2014/11/19 15:01:15 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy pypy3 )
inherit distutils-r1
@@ -19,8 +19,7 @@ IUSE="doc examples test"
DEPEND="
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
python_compile_all() {
use doc && emake -C doc html