summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-02 10:28:05 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-02 10:28:05 +0000
commitb7848d90146c6a5656f9bb21fdd0755dce1d5526 (patch)
treee463d817e6383a02473d4e7ff06420e9e87f0398 /dev-python/peewee
parentset PYTHON_USEDEP tp peewee (diff)
downloadgentoo-2-b7848d90146c6a5656f9bb21fdd0755dce1d5526.tar.gz
gentoo-2-b7848d90146c6a5656f9bb21fdd0755dce1d5526.tar.bz2
gentoo-2-b7848d90146c6a5656f9bb21fdd0755dce1d5526.zip
bump; fix test phase, assisted with support testing by eroen
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/ChangeLog9
-rw-r--r--dev-python/peewee/peewee-2.1.4.ebuild30
-rw-r--r--dev-python/peewee/peewee-2.1.5.ebuild30
-rw-r--r--dev-python/peewee/peewee-2.1.6.ebuild33
-rw-r--r--dev-python/peewee/peewee-2.1.7.ebuild33
-rw-r--r--dev-python/peewee/peewee-2.2.4.ebuild (renamed from dev-python/peewee/peewee-2.2.1.ebuild)5
6 files changed, 11 insertions, 129 deletions
diff --git a/dev-python/peewee/ChangeLog b/dev-python/peewee/ChangeLog
index 3d943b1dcb08..44005e39dd2c 100644
--- a/dev-python/peewee/ChangeLog
+++ b/dev-python/peewee/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/peewee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.8 2014/06/02 05:28:57 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.9 2014/06/02 10:28:05 idella4 Exp $
+
+*peewee-2.2.4 (02 Jun 2014)
+
+ 02 Jun 2014; Ian Delaney <idella4@gentoo.org> +peewee-2.2.4.ebuild,
+ -peewee-2.1.4.ebuild, -peewee-2.1.5.ebuild, -peewee-2.1.6.ebuild,
+ -peewee-2.1.7.ebuild, -peewee-2.2.1.ebuild:
+ bump; fix test phase, assisted with support testing by eroen
*peewee-2.2.1 (02 Jun 2014)
diff --git a/dev-python/peewee/peewee-2.1.4.ebuild b/dev-python/peewee/peewee-2.1.4.ebuild
deleted file mode 100644
index 097b3d2231f0..000000000000
--- a/dev-python/peewee/peewee-2.1.4.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.1.4.ebuild,v 1.3 2013/08/17 04:30:56 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-RESTRICT="test" # wants to access the local PG instance - not OK
-
-inherit distutils-r1
-
-DESCRIPTION="Small python ORM"
-HOMEPAGE="https://github.com/coleifer/peewee/"
-SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/apsw[${PYTHON_USEDEP}]
- dev-python/psycopg[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-python/peewee/peewee-2.1.5.ebuild b/dev-python/peewee/peewee-2.1.5.ebuild
deleted file mode 100644
index 1d43535de421..000000000000
--- a/dev-python/peewee/peewee-2.1.5.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.1.5.ebuild,v 1.1 2014/05/09 06:07:55 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-RESTRICT="test" # wants to access the local PG instance - not OK
-
-inherit distutils-r1
-
-DESCRIPTION="Small python ORM"
-HOMEPAGE="https://github.com/coleifer/peewee/"
-SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/apsw[${PYTHON_USEDEP}]
- dev-python/psycopg[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-python/peewee/peewee-2.1.6.ebuild b/dev-python/peewee/peewee-2.1.6.ebuild
deleted file mode 100644
index 6c18fbbf0883..000000000000
--- a/dev-python/peewee/peewee-2.1.6.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.1.6.ebuild,v 1.1 2014/05/14 23:21:07 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Small python ORM"
-HOMEPAGE="https://github.com/coleifer/peewee/"
-SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/apsw[${PYTHON_USEDEP}]
- dev-python/psycopg[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- "${PYTHON}" ./runtests.py || die "tests failed"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( example/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/peewee/peewee-2.1.7.ebuild b/dev-python/peewee/peewee-2.1.7.ebuild
deleted file mode 100644
index 21f02515064d..000000000000
--- a/dev-python/peewee/peewee-2.1.7.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.1.7.ebuild,v 1.1 2014/05/20 08:11:00 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Small python ORM"
-HOMEPAGE="https://github.com/coleifer/peewee/"
-SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/apsw[${PYTHON_USEDEP}]
- dev-python/psycopg[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- "${PYTHON}" ./runtests.py || die "tests failed"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( example/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/peewee/peewee-2.2.1.ebuild b/dev-python/peewee/peewee-2.2.4.ebuild
index bbb7b6432fc1..3a801d2596f4 100644
--- a/dev-python/peewee/peewee-2.2.1.ebuild
+++ b/dev-python/peewee/peewee-2.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.2.1.ebuild,v 1.1 2014/06/02 05:28:57 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.2.4.ebuild,v 1.1 2014/06/02 10:28:05 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -23,13 +23,14 @@ DEPEND="${RDEPEND}
dev-python/psycopg[${PYTHON_USEDEP}]
dev-python/django[${PYTHON_USEDEP}]
)"
+# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
+DISTUTILS_IN_SOURCE_BUILD=1
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
- # https://github.com/coleifer/peewee/issues/367
"${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
}