summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-09 04:31:48 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-09 04:31:48 +0000
commit2f0e9d3bacaf76f7112f35e3620decbeea2bb040 (patch)
treef9ccca68c3d6dd1302719cba8e7fa4ef189cbe44 /dev-python/peewee
parentadd version 2.0.1 (diff)
downloadgentoo-2-2f0e9d3bacaf76f7112f35e3620decbeea2bb040.tar.gz
gentoo-2-2f0e9d3bacaf76f7112f35e3620decbeea2bb040.tar.bz2
gentoo-2-2f0e9d3bacaf76f7112f35e3620decbeea2bb040.zip
bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/ChangeLog7
-rw-r--r--dev-python/peewee/peewee-2.4.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/peewee/ChangeLog b/dev-python/peewee/ChangeLog
index 319cd411b823..1b9e861b5ecc 100644
--- a/dev-python/peewee/ChangeLog
+++ b/dev-python/peewee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/peewee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.18 2014/11/01 10:13:21 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.19 2014/11/09 04:31:48 idella4 Exp $
+
+*peewee-2.4.1 (09 Nov 2014)
+
+ 09 Nov 2014; Ian Delaney <idella4@gentoo.org> +peewee-2.4.1.ebuild:
+ bump
*peewee-2.4.0 (01 Nov 2014)
diff --git a/dev-python/peewee/peewee-2.4.1.ebuild b/dev-python/peewee/peewee-2.4.1.ebuild
new file mode 100644
index 000000000000..e38705f82a9f
--- /dev/null
+++ b/dev-python/peewee/peewee-2.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.4.1.ebuild,v 1.1 2014/11/09 04:31:48 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/apsw[${PYTHON_USEDEP}]
+ dev-python/psycopg[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ )"
+# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}