summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2012-06-03 16:25:18 +0000
committerMarien Zwart <marienz@gentoo.org>2012-06-03 16:25:18 +0000
commit559eeabaa710b274230a763f3fe752b46de2a897 (patch)
tree4ef86695a48ebd938d29dcd1ba3a10d60f5d8415 /dev-python/oauthlib
parentalpha/ia64/sparc stable wrt #415393 (diff)
downloadgentoo-2-559eeabaa710b274230a763f3fe752b46de2a897.tar.gz
gentoo-2-559eeabaa710b274230a763f3fe752b46de2a897.tar.bz2
gentoo-2-559eeabaa710b274230a763f3fe752b46de2a897.zip
Restrict tests for pypy, as they make assumptions about dict order.
(Portage version: 2.2.0_alpha109/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/oauthlib')
-rw-r--r--dev-python/oauthlib/ChangeLog5
-rw-r--r--dev-python/oauthlib/oauthlib-0.1.3.ebuild4
2 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/oauthlib/ChangeLog b/dev-python/oauthlib/ChangeLog
index c1de4f34fc8d..c316c9c742f9 100644
--- a/dev-python/oauthlib/ChangeLog
+++ b/dev-python/oauthlib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/oauthlib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oauthlib/ChangeLog,v 1.5 2012/05/28 17:56:14 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oauthlib/ChangeLog,v 1.6 2012/06/03 16:25:18 marienz Exp $
+
+ 03 Jun 2012; Marien Zwart <marienz@gentoo.org> oauthlib-0.1.3.ebuild:
+ Restrict tests for pypy, as they make assumptions about dict order.
28 May 2012; Markus Meier <maekke@gentoo.org> oauthlib-0.1.3.ebuild:
add ~arm, bug #415187
diff --git a/dev-python/oauthlib/oauthlib-0.1.3.ebuild b/dev-python/oauthlib/oauthlib-0.1.3.ebuild
index 662e48d82f45..ac80b5caf8d5 100644
--- a/dev-python/oauthlib/oauthlib-0.1.3.ebuild
+++ b/dev-python/oauthlib/oauthlib-0.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oauthlib/oauthlib-0.1.3.ebuild,v 1.5 2012/05/28 17:56:14 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oauthlib/oauthlib-0.1.3.ebuild,v 1.6 2012/06/03 16:25:18 marienz Exp $
EAPI="4"
@@ -8,6 +8,8 @@ PYTHON_DEPEND="2:2.6"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.5 3.*"
DISTUTILS_SRC_TEST="nosetests"
+# Tests depend on dict order, see https://github.com/idangazit/oauthlib/issues/40
+PYTHON_TESTS_RESTRICTED_ABIS="*-pypy-*"
inherit distutils