summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-11-05 23:21:59 +0000
committerPacho Ramos <pacho@gentoo.org>2010-11-05 23:21:59 +0000
commit35386dffe5b1d4d8eb507914dde881ded4fd20f2 (patch)
treeead8ecab60ad6f4d827a4090646502c911991ed5 /dev-python/libwnck-python
parentMoving dev-libs/luafilesystem to dev-lua/luafilesystem (diff)
downloadgentoo-2-35386dffe5b1d4d8eb507914dde881ded4fd20f2.tar.gz
gentoo-2-35386dffe5b1d4d8eb507914dde881ded4fd20f2.tar.bz2
gentoo-2-35386dffe5b1d4d8eb507914dde881ded4fd20f2.zip
Version bump for Gnome 2.32.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/libwnck-python')
-rw-r--r--dev-python/libwnck-python/ChangeLog7
-rw-r--r--dev-python/libwnck-python/libwnck-python-2.32.0.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/libwnck-python/ChangeLog b/dev-python/libwnck-python/ChangeLog
index 7cd2e83437e7..244f1fc68a5e 100644
--- a/dev-python/libwnck-python/ChangeLog
+++ b/dev-python/libwnck-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/libwnck-python
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libwnck-python/ChangeLog,v 1.42 2010/10/14 22:34:21 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libwnck-python/ChangeLog,v 1.43 2010/11/05 23:21:59 pacho Exp $
+
+*libwnck-python-2.32.0 (05 Nov 2010)
+
+ 05 Nov 2010; Pacho Ramos <pacho@gentoo.org> +libwnck-python-2.32.0.ebuild:
+ Version bump for Gnome 2.32.
14 Oct 2010; Markus Meier <maekke@gentoo.org>
libwnck-python-2.30.2-r1.ebuild:
diff --git a/dev-python/libwnck-python/libwnck-python-2.32.0.ebuild b/dev-python/libwnck-python/libwnck-python-2.32.0.ebuild
new file mode 100644
index 000000000000..4cb383062653
--- /dev/null
+++ b/dev-python/libwnck-python/libwnck-python-2.32.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libwnck-python/libwnck-python-2.32.0.ebuild,v 1.1 2010/11/05 23:21:59 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+G_PY_PN="gnome-python-desktop"
+G_PY_BINDINGS="wnck"
+
+inherit gnome-python-common eutils
+
+DESCRIPTION="Python bindings for the libwnck library"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=x11-libs/libwnck-2.19.3
+ !<dev-python/gnome-python-desktop-2.22.0-r10"
+DEPEND="${RDEPEND}"
+
+EXAMPLES="examples/wnck_example.py"
+
+src_prepare() {
+ # Fix three enum items that should be flags, upstream bug #616306
+ epatch "${FILESDIR}/${PN}-2.30.2-flagsfix.patch"
+ gnome-python-common_src_prepare
+}