summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-07-09 01:03:56 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-07-09 01:03:56 +0000
commit7037290f0e26d49db4eaaa0946ba8f8b77742f5f (patch)
treee3a289a9571a73b73daceec037c4dfede12db36d /dev-python/libnatpmp
parentDrop old version. (diff)
downloadgentoo-2-7037290f0e26d49db4eaaa0946ba8f8b77742f5f.tar.gz
gentoo-2-7037290f0e26d49db4eaaa0946ba8f8b77742f5f.tar.bz2
gentoo-2-7037290f0e26d49db4eaaa0946ba8f8b77742f5f.zip
Rev bump to avoid in places EAPI change, bug #476166
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-python/libnatpmp')
-rw-r--r--dev-python/libnatpmp/ChangeLog9
-rw-r--r--dev-python/libnatpmp/libnatpmp-20120821-r1.ebuild28
-rw-r--r--dev-python/libnatpmp/libnatpmp-20120821.ebuild15
3 files changed, 44 insertions, 8 deletions
diff --git a/dev-python/libnatpmp/ChangeLog b/dev-python/libnatpmp/ChangeLog
index bcfb150da81e..69df0317759e 100644
--- a/dev-python/libnatpmp/ChangeLog
+++ b/dev-python/libnatpmp/ChangeLog
@@ -1,7 +1,14 @@
+
+*libnatpmp-20120821-r1 (09 Jul 2013)
+
+ 09 Jul 2013; Anthony G. Basile <blueness@gentoo.org>
+ libnatpmp-20120821.ebuild, +libnatpmp-20120821-r1.ebuild:
+ Rev bump to avoid in places EAPI change, bug #476166
+
09 Jul 2013; Anthony G. Basile <blueness@gentoo.org>
libnatpmp-20120821.ebuild:
- Convert to distutils-r1
+ Convert to distutils-r1, bug #476166
*libnatpmp-20120821 (27 Aug 2012)
diff --git a/dev-python/libnatpmp/libnatpmp-20120821-r1.ebuild b/dev-python/libnatpmp/libnatpmp-20120821-r1.ebuild
new file mode 100644
index 000000000000..8fc57314e96a
--- /dev/null
+++ b/dev-python/libnatpmp/libnatpmp-20120821-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libnatpmp/libnatpmp-20120821-r1.ebuild,v 1.1 2013/07/09 01:03:56 blueness Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for libnatpmp, an alternative protocol to UPnP IGD."
+HOMEPAGE="http://miniupnp.free.fr/libnatpmp.html"
+SRC_URI="http://miniupnp.free.fr/files/download.php?file=${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=net-libs/${P}"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ epatch "${FILESDIR}"/link-against-system-lib.patch
+
+ #These are installed by net-libs/libnatpmp
+ rm -f Changelog.txt README || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/libnatpmp/libnatpmp-20120821.ebuild b/dev-python/libnatpmp/libnatpmp-20120821.ebuild
index f38b9b325b46..014aa372165b 100644
--- a/dev-python/libnatpmp/libnatpmp-20120821.ebuild
+++ b/dev-python/libnatpmp/libnatpmp-20120821.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libnatpmp/libnatpmp-20120821.ebuild,v 1.2 2013/07/09 00:13:14 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libnatpmp/libnatpmp-20120821.ebuild,v 1.3 2013/07/09 01:03:56 blueness Exp $
-EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy2_0 )
+EAPI=3
+PYTHON_DEPEND=2
+RESTRICT_PYTHON_ABIS="3.*"
-inherit distutils-r1
+inherit eutils distutils
DESCRIPTION="Python module for libnatpmp, an alternative protocol to UPnP IGD."
HOMEPAGE="http://miniupnp.free.fr/libnatpmp.html"
@@ -16,13 +17,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="=net-libs/${P}"
+DEPEND="=net-libs/${PF}"
RDEPEND="${DEPEND}"
-python_prepare_all() {
+src_prepare() {
epatch "${FILESDIR}"/link-against-system-lib.patch
+ distutils_src_prepare
#These are installed by net-libs/libnatpmp
rm -f Changelog.txt README || die
- distutils-r1_python_prepare_all
}