summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2008-03-12 14:54:01 +0000
committerRobert Buchholz <rbu@gentoo.org>2008-03-12 14:54:01 +0000
commite8055c026618ec7c4b3b1fe72d55696c111766b9 (patch)
tree4739bccb9b6d69c03abf77a00955d7cc72d7d3f7 /dev-python/kaa-base
parentVersion bump, for bug #210249. (diff)
downloadgentoo-2-e8055c026618ec7c4b3b1fe72d55696c111766b9.tar.gz
gentoo-2-e8055c026618ec7c4b3b1fe72d55696c111766b9.tar.bz2
gentoo-2-e8055c026618ec7c4b3b1fe72d55696c111766b9.zip
Version bump, thanks to alpiturchi (bug #210343)
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/kaa-base')
-rw-r--r--dev-python/kaa-base/ChangeLog9
-rw-r--r--dev-python/kaa-base/kaa-base-0.3.0.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-python/kaa-base/ChangeLog b/dev-python/kaa-base/ChangeLog
index 22bcf3a06fa7..fcf11e8170d1 100644
--- a/dev-python/kaa-base/ChangeLog
+++ b/dev-python/kaa-base/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/kaa-base
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-base/ChangeLog,v 1.6 2007/10/06 20:13:26 dertobi123 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-base/ChangeLog,v 1.7 2008/03/12 14:54:01 rbu Exp $
+
+*kaa-base-0.3.0 (12 Mar 2008)
+
+ 12 Mar 2008; Robert Buchholz <rbu@gentoo.org> +kaa-base-0.3.0.ebuild:
+ Version bump, thanks to alpiturchi (bug #210343)
06 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
kaa-base-0.1.3.ebuild:
diff --git a/dev-python/kaa-base/kaa-base-0.3.0.ebuild b/dev-python/kaa-base/kaa-base-0.3.0.ebuild
new file mode 100644
index 000000000000..0020c71a6821
--- /dev/null
+++ b/dev-python/kaa-base/kaa-base-0.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-base/kaa-base-0.3.0.ebuild,v 1.1 2008/03/12 14:54:01 rbu Exp $
+
+inherit python eutils distutils
+
+DESCRIPTION="Basic Framework for all Kaa Python Modules."
+HOMEPAGE="http://freevo.sourceforge.net/kaa/"
+SRC_URI="mirror://sourceforge/freevo/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="sqlite lirc"
+
+RDEPEND="dev-libs/libxml2
+ dev-python/pynotifier
+ sqlite? ( >=dev-libs/glib-2.4.0 >=dev-python/pysqlite-2.2 )
+ lirc? ( dev-python/pylirc )"
+
+src_unpack() {
+ distutils_src_unpack
+
+ cd "${S}"
+ rm -rf src/notifier/pynotifier
+}
+
+pkg_setup() {
+ if ! built_with_use dev-libs/libxml2 python; then
+ eerror "dev-libs/libxml2 must be built with the 'python' USE flag"
+ die "Recompile dev-libs/libxml2 with the 'python' USE flag enabled"
+ fi
+}