summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-14 07:17:13 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-14 07:17:13 +0000
commit027d30416d355a80e1128e6d78ce13ba087af2e4 (patch)
tree5aa0833e2a1055e26f5a71ad1fac0a76b90fc382 /dev-python/gst-python
parentold (diff)
downloadgentoo-2-027d30416d355a80e1128e6d78ce13ba087af2e4.tar.gz
gentoo-2-027d30416d355a80e1128e6d78ce13ba087af2e4.tar.bz2
gentoo-2-027d30416d355a80e1128e6d78ce13ba087af2e4.zip
Revision bump to correctly handle bytecompiling and autotools.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/ChangeLog8
-rw-r--r--dev-python/gst-python/gst-python-0.10.15-r1.ebuild (renamed from dev-python/gst-python/gst-python-0.10.15.ebuild)15
2 files changed, 14 insertions, 9 deletions
diff --git a/dev-python/gst-python/ChangeLog b/dev-python/gst-python/ChangeLog
index a48671de0da3..be4958c70a41 100644
--- a/dev-python/gst-python/ChangeLog
+++ b/dev-python/gst-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gst-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.49 2009/05/13 15:46:37 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.50 2009/05/14 07:17:13 ssuominen Exp $
+
+*gst-python-0.10.15-r1 (14 May 2009)
+
+ 14 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ -gst-python-0.10.15.ebuild, +gst-python-0.10.15-r1.ebuild:
+ Revision bump to correctly handle bytecompiling and autotools.
*gst-python-0.10.15 (13 May 2009)
diff --git a/dev-python/gst-python/gst-python-0.10.15.ebuild b/dev-python/gst-python/gst-python-0.10.15-r1.ebuild
index fe2920df11bf..6fc0ca91be9e 100644
--- a/dev-python/gst-python/gst-python-0.10.15.ebuild
+++ b/dev-python/gst-python/gst-python-0.10.15-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.15.ebuild,v 1.1 2009/05/13 15:46:37 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.15-r1.ebuild,v 1.1 2009/05/14 07:17:13 ssuominen Exp $
+EAPI=2
NEED_PYTHON=2.4
-
inherit autotools eutils multilib python
DESCRIPTION="A Python Interface to GStreamer"
@@ -22,16 +22,15 @@ RDEPEND="|| ( >=dev-python/pygobject-2.11.2 >=dev-python/pygtk-2.6.3 )
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-0.10.9-lazy.patch
-
- eautoconf
+ rm -f py-compile
+ ln -s $(type -P true) py-compile
+ AT_M4DIR="common/m4" eautoreconf
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README TODO
if use examples; then