summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-06-14 18:54:59 +0000
committerTim Harder <radhermit@gentoo.org>2013-06-14 18:54:59 +0000
commit6c3caa69d155324ca2e74260f9c960f0c9dbfd2a (patch)
treeb984b2214447adcd500ed0d27198b0c7270d93b5 /dev-python/gdata
parentVersion bumps (diff)
downloadgentoo-2-6c3caa69d155324ca2e74260f9c960f0c9dbfd2a.tar.gz
gentoo-2-6c3caa69d155324ca2e74260f9c960f0c9dbfd2a.tar.bz2
gentoo-2-6c3caa69d155324ca2e74260f9c960f0c9dbfd2a.zip
Version bump.
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/gdata')
-rw-r--r--dev-python/gdata/ChangeLog7
-rw-r--r--dev-python/gdata/gdata-2.0.18.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/gdata/ChangeLog b/dev-python/gdata/ChangeLog
index e353594e1457..6acbe5eb407a 100644
--- a/dev-python/gdata/ChangeLog
+++ b/dev-python/gdata/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gdata
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.109 2013/06/14 08:22:31 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.110 2013/06/14 18:54:59 radhermit Exp $
+
+*gdata-2.0.18 (14 Jun 2013)
+
+ 14 Jun 2013; Tim Harder <radhermit@gentoo.org> +gdata-2.0.18.ebuild:
+ Version bump.
*gdata-2.0.17-r1 (14 Jun 2013)
diff --git a/dev-python/gdata/gdata-2.0.18.ebuild b/dev-python/gdata/gdata-2.0.18.ebuild
new file mode 100644
index 000000000000..f7d01a708418
--- /dev/null
+++ b/dev-python/gdata/gdata-2.0.18.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/gdata-2.0.18.ebuild,v 1.1 2013/06/14 18:54:59 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy2_0 )
+PYTHON_REQ_USE="ssl(+),xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python client library for Google data APIs"
+HOMEPAGE="http://code.google.com/p/gdata-python-client/ http://pypi.python.org/pypi/gdata"
+SRC_URI="http://gdata-python-client.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="examples"
+
+python_test() {
+ # run_service_tests.py requires interaction (and a valid Google account), so skip it.
+ "${PYTHON}" tests/run_data_tests.py -v || die "Test failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( samples/. )
+ distutils-r1_python_install_all
+}