summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-05 18:20:32 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-05 18:20:32 +0000
commit20ea05a9ff8caeee6d83185b2a0582278b9ccd6b (patch)
treef164e7144c8467f9bb94c0c7f3864b8c68463676 /dev-python/futures
parentAdd systemd file bug #475874 (diff)
downloadgentoo-2-20ea05a9ff8caeee6d83185b2a0582278b9ccd6b.tar.gz
gentoo-2-20ea05a9ff8caeee6d83185b2a0582278b9ccd6b.tar.bz2
gentoo-2-20ea05a9ff8caeee6d83185b2a0582278b9ccd6b.zip
bump; custom tarball prepared, version tarball topped up and located in devspace, fixes Bug #474688
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/futures')
-rw-r--r--dev-python/futures/ChangeLog8
-rw-r--r--dev-python/futures/futures-2.1.4.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/futures/ChangeLog b/dev-python/futures/ChangeLog
index aa7e019c2910..4c857dbafc55 100644
--- a/dev-python/futures/ChangeLog
+++ b/dev-python/futures/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/futures
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/futures/ChangeLog,v 1.4 2013/04/05 20:06:13 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/futures/ChangeLog,v 1.5 2013/07/05 18:20:32 idella4 Exp $
+
+*futures-2.1.4 (05 Jul 2013)
+
+ 05 Jul 2013; Ian Delaney <idella4@gentoo.org> +futures-2.1.4.ebuild:
+ bump; custom tarball prepared, version tarball topped up and located in
+ devspace, fixes Bug #474688
05 Apr 2013; Mike Gilbert <floppym@gentoo.org> futures-2.1.3-r1.ebuild:
Fixup distutils-r1 conversion.
diff --git a/dev-python/futures/futures-2.1.4.ebuild b/dev-python/futures/futures-2.1.4.ebuild
new file mode 100644
index 000000000000..918625475bf0
--- /dev/null
+++ b/dev-python/futures/futures-2.1.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/futures/futures-2.1.4.ebuild,v 1.1 2013/07/05 18:20:32 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1} )
+inherit distutils-r1
+
+DESCRIPTION="Backport of the concurrent.futures package from Python 3.2"
+HOMEPAGE="http://code.google.com/p/pythonfutures http://pypi.python.org/pypi/futures"
+SRC_URI="http://dev.gentoo.org/~idella4/tarballs/${P}-20130706.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+DOCS=( CHANGES )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" test_futures.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}