summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-22 16:17:58 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-22 16:17:58 +0000
commita1edd349597226c58b0ed1a74c762ebf6f7f4d53 (patch)
treeb5acba21481eb03f7c144e1a2eef3704e160716d /dev-python/functest/functest-0.8.8.ebuild
parentarm stable, bug #327777 (diff)
downloadgentoo-2-a1edd349597226c58b0ed1a74c762ebf6f7f4d53.tar.gz
gentoo-2-a1edd349597226c58b0ed1a74c762ebf6f7f4d53.tar.bz2
gentoo-2-a1edd349597226c58b0ed1a74c762ebf6f7f4d53.zip
Set SUPPORT_PYTHON_ABIS. Fix tests (bug #321985).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/functest/functest-0.8.8.ebuild')
-rw-r--r--dev-python/functest/functest-0.8.8.ebuild41
1 files changed, 27 insertions, 14 deletions
diff --git a/dev-python/functest/functest-0.8.8.ebuild b/dev-python/functest/functest-0.8.8.ebuild
index 6b9db606584c..227fa61ae60f 100644
--- a/dev-python/functest/functest-0.8.8.ebuild
+++ b/dev-python/functest/functest-0.8.8.ebuild
@@ -1,23 +1,36 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/functest/functest-0.8.8.ebuild,v 1.3 2009/07/27 07:14:37 mr_bones_ Exp $
-# Ebuild generated by g-pypi 0.2.2 (rev. 214)
+# $Header: /var/cvsroot/gentoo-x86/dev-python/functest/functest-0.8.8.ebuild,v 1.4 2010/07/22 16:17:58 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
-EAPI="2"
inherit distutils
-DESCRIPTION="Functest is a test tool/framework for testing in python"
-HOMEPAGE="http://code.google.com/p/functest/"
-SRC_URI="http://cheeseshop.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+DESCRIPTION="Functest is a test tool/framework for testing in Python"
+HOMEPAGE="http://code.google.com/p/functest/ http://pypi.python.org/pypi/functest"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
LICENSE="Apache-2.0"
-KEYWORDS="~x86"
SLOT="0"
-IUSE="test"
-DEPEND="dev-python/setuptools
- virtual/python
- test? ( >=dev-python/nose-0.10.4 )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
RDEPEND="${DEPEND}"
-src_test(){
- PYTHONPATH=. nosetests || die "Test failed"
+src_test() {
+ PATH="scripts:${PATH}" distutils_src_test
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/tests"
+ }
+ python_execute_function -q delete_tests
}