summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-12-10 03:20:51 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-12-10 03:20:51 +0000
commit5ff060adb357edd0215293b2e4bfba7b2f770bef (patch)
tree508db052270231a96ce7c8eea768840191a644bf /dev-python/flask-script
parentBump (diff)
downloadgentoo-2-5ff060adb357edd0215293b2e4bfba7b2f770bef.tar.gz
gentoo-2-5ff060adb357edd0215293b2e4bfba7b2f770bef.tar.bz2
gentoo-2-5ff060adb357edd0215293b2e4bfba7b2f770bef.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/flask-script')
-rw-r--r--dev-python/flask-script/ChangeLog7
-rw-r--r--dev-python/flask-script/flask-script-0.6.6.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/flask-script/ChangeLog b/dev-python/flask-script/ChangeLog
index 81d4e5e51d0f..a8e6fed0ba45 100644
--- a/dev-python/flask-script/ChangeLog
+++ b/dev-python/flask-script/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-script
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/ChangeLog,v 1.11 2013/11/26 05:40:32 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/ChangeLog,v 1.12 2013/12/10 03:20:51 patrick Exp $
+
+*flask-script-0.6.6 (10 Dec 2013)
+
+ 10 Dec 2013; Patrick Lauer <patrick@gentoo.org> +flask-script-0.6.6.ebuild:
+ Bump
*flask-script-0.6.3 (26 Nov 2013)
diff --git a/dev-python/flask-script/flask-script-0.6.6.ebuild b/dev-python/flask-script/flask-script-0.6.6.ebuild
new file mode 100644
index 000000000000..3a07ea1a4bf8
--- /dev/null
+++ b/dev-python/flask-script/flask-script-0.6.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/flask-script-0.6.6.ebuild,v 1.1 2013/12/10 03:20:51 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_3} )
+
+inherit distutils-r1
+
+MY_PN="Flask-Script"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flask support for writing external scripts."
+HOMEPAGE="http://packages.python.org/Flask-Script/ http://pypi.python.org/pypi/Flask-Script"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/flask-0.10.1-r1[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation by" ${PYTHON}
+ PYTHONPATH=".." emake -C docs html || die "Generation of documentation failed"
+ fi
+}
+
+python_test() {
+ py.test tests.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}