summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-02-22 05:43:01 +0000
committerSebastian Pipping <sping@gentoo.org>2011-02-22 05:43:01 +0000
commiteb4df58e7c944d8905266276ef63aa93c0336ec6 (patch)
tree37d8066bb6637144cc37065b71c683103a7d372c /dev-python/feedparser
parentp.mask yafc, atftp, gwydion-dylan for removal in 60 days (diff)
downloadgentoo-2-eb4df58e7c944d8905266276ef63aa93c0336ec6.tar.gz
gentoo-2-eb4df58e7c944d8905266276ef63aa93c0336ec6.tar.bz2
gentoo-2-eb4df58e7c944d8905266276ef63aa93c0336ec6.zip
dev-python/feedparser: Bump to 5.0.1
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/feedparser')
-rw-r--r--dev-python/feedparser/ChangeLog7
-rw-r--r--dev-python/feedparser/feedparser-5.0.1.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/feedparser/ChangeLog b/dev-python/feedparser/ChangeLog
index d8c4ca2d091c..96241c769b53 100644
--- a/dev-python/feedparser/ChangeLog
+++ b/dev-python/feedparser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/feedparser
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/ChangeLog,v 1.22 2011/01/26 12:25:33 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/ChangeLog,v 1.23 2011/02/22 05:43:01 sping Exp $
+
+*feedparser-5.0.1 (22 Feb 2011)
+
+ 22 Feb 2011; Sebastian Pipping <sping@gentoo.org> +feedparser-5.0.1.ebuild:
+ Bump to 5.0.1, looks trivial
*feedparser-5.0 (26 Jan 2011)
diff --git a/dev-python/feedparser/feedparser-5.0.1.ebuild b/dev-python/feedparser/feedparser-5.0.1.ebuild
new file mode 100644
index 000000000000..05ae01471445
--- /dev/null
+++ b/dev-python/feedparser/feedparser-5.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/feedparser-5.0.1.ebuild,v 1.1 2011/02/22 05:43:01 sping Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*" # See README-PYTHON3 in tarball if you want to work on this
+
+inherit distutils
+
+DESCRIPTION="Parse RSS and Atom feeds in Python"
+HOMEPAGE="http://www.feedparser.org/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+
+DEPEND=""
+RDEPEND=""
+
+PYTHON_MODNAME="feedparser.py"
+DOCS=( LICENSE NEWS )
+
+src_test() {
+ testing() {
+ cd feedparser || die
+ "$(PYTHON)" ${PN}test.py || die
+ }
+ python_execute_function testing
+}