summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-12-30 04:26:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-12-30 04:26:33 +0000
commitcbe690ccc18d96607bd8bfa6936d793b09e50019 (patch)
treebeae0788a9a0d79feee2def907d0180cacc4e4a8 /dev-python/chameleon
parentStable for HPPA (bug #396435). (diff)
downloadgentoo-2-cbe690ccc18d96607bd8bfa6936d793b09e50019.tar.gz
gentoo-2-cbe690ccc18d96607bd8bfa6936d793b09e50019.tar.bz2
gentoo-2-cbe690ccc18d96607bd8bfa6936d793b09e50019.zip
Bump for #393593
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/chameleon')
-rw-r--r--dev-python/chameleon/ChangeLog7
-rw-r--r--dev-python/chameleon/chameleon-2.6.1.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-python/chameleon/ChangeLog b/dev-python/chameleon/ChangeLog
index 26d7ea611807..90460e8adb9d 100644
--- a/dev-python/chameleon/ChangeLog
+++ b/dev-python/chameleon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/chameleon
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/ChangeLog,v 1.6 2011/09/14 08:26:17 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/ChangeLog,v 1.7 2011/12/30 04:26:33 patrick Exp $
+
+*chameleon-2.6.1 (30 Dec 2011)
+
+ 30 Dec 2011; Patrick Lauer <patrick@gentoo.org> +chameleon-2.6.1.ebuild:
+ Bump for #393593
*chameleon-2.4.3 (14 Sep 2011)
diff --git a/dev-python/chameleon/chameleon-2.6.1.ebuild b/dev-python/chameleon/chameleon-2.6.1.ebuild
new file mode 100644
index 000000000000..a39573ee6a45
--- /dev/null
+++ b/dev-python/chameleon/chameleon-2.6.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/chameleon-2.6.1.ebuild,v 1.1 2011/12/30 04:26:33 patrick Exp $
+
+EAPI=3
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.7 3"
+RESTRICT_PYTHON_ABIS="2.[456]"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+MY_PN="Chameleon"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Fast HTML/XML template compiler for Python"
+HOMEPAGE="http://chameleon.repoze.org http://pypi.python.org/pypi/Chameleon"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake html || die "make html failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests_and_incompatible_modules() {
+ rm -fr "${ED}$(python_get_sitedir)/chameleon/tests"
+
+ if [[ "$(python_get_version -l --major)" == "3" ]]; then
+ rm -f "${ED}$(python_get_sitedir)/chameleon/"{benchmark.py,py25.py}
+ fi
+ }
+ python_execute_function -q delete_tests_and_incompatible_modules
+
+ if use doc; then
+ pushd _build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static
+ popd > /dev/null
+ fi
+}