summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2012-06-22 15:23:20 +0000
committerMarien Zwart <marienz@gentoo.org>2012-06-22 15:23:20 +0000
commit0c412fd73fa1d29cb13aa8a51bc430eba01ebebd (patch)
treedb2ed4cf3ce134e8fb3549b2c97aed52b408bb72 /dev-python/carbon
parentMarking libnatspec-0.2.6 ppc64 for bug 420725 (diff)
downloadgentoo-2-0c412fd73fa1d29cb13aa8a51bc430eba01ebebd.tar.gz
gentoo-2-0c412fd73fa1d29cb13aa8a51bc430eba01ebebd.tar.bz2
gentoo-2-0c412fd73fa1d29cb13aa8a51bc430eba01ebebd.zip
Version bump, fix install paths (bug #417221, thanks to Tom Prince and Ian Delaney). Remove old broken version.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/carbon')
-rw-r--r--dev-python/carbon/ChangeLog9
-rw-r--r--dev-python/carbon/carbon-0.9.10.ebuild51
-rw-r--r--dev-python/carbon/files/no-data-files.patch26
3 files changed, 85 insertions, 1 deletions
diff --git a/dev-python/carbon/ChangeLog b/dev-python/carbon/ChangeLog
index 8bc59f059e2b..b66bc7627249 100644
--- a/dev-python/carbon/ChangeLog
+++ b/dev-python/carbon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/carbon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/carbon/ChangeLog,v 1.2 2012/03/22 07:59:30 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/carbon/ChangeLog,v 1.3 2012/06/22 15:23:20 marienz Exp $
+
+*carbon-0.9.10 (22 Jun 2012)
+
+ 22 Jun 2012; Marien Zwart <marienz@gentoo.org> +carbon-0.9.10.ebuild,
+ +files/no-data-files.patch:
+ Version bump, fix install paths (bug #417221, thanks to Tom Prince and Ian
+ Delaney). Remove old broken version.
*carbon-0.9.9-r2 (22 Mar 2012)
diff --git a/dev-python/carbon/carbon-0.9.10.ebuild b/dev-python/carbon/carbon-0.9.10.ebuild
new file mode 100644
index 000000000000..e8a32e1f9c2b
--- /dev/null
+++ b/dev-python/carbon/carbon-0.9.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/carbon/carbon-0.9.10.ebuild,v 1.1 2012/06/22 15:23:20 marienz Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+inherit distutils eutils
+
+DESCRIPTION="Backend data caching and persistence daemon for Graphite"
+HOMEPAGE="http://graphite.wikidot.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/twisted
+ dev-python/whisper
+ dev-python/txAMQP"
+
+src_prepare() {
+ # This sets prefix to /opt/graphite. We want FHS-style paths instead.
+ rm setup.cfg || die
+ # Do not install the configuration and data files. We install them
+ #somewhere sensible by hand.
+ epatch "${FILESDIR}/no-data-files.patch"
+
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /etc/carbon
+ doins conf/*
+
+ dodir /var/log/carbon /var/lib/carbon/{whisper,lists,rrd}
+}
+
+pkg_postinst() {
+ einfo 'This ebuild installs carbon into FHS-style paths.'
+ einfo 'You will probably have to set GRAPHITE_CONF_DIR to /etc/carbon'
+ einfo 'and GRAPHITE_STORAGE_DIR to /var/lib/carbon to make use of this'
+ einfo '(see /etc/carbon/carbon.conf.example).'
+}
diff --git a/dev-python/carbon/files/no-data-files.patch b/dev-python/carbon/files/no-data-files.patch
new file mode 100644
index 000000000000..7b0c52f3948b
--- /dev/null
+++ b/dev-python/carbon/files/no-data-files.patch
@@ -0,0 +1,26 @@
+Do not install the empty storage dirs and config files to the wrong
+location (the ebuild installs them to the right location by hand).
+
+See Gentoo bug #417221.
+
+--- setup.py
++++ setup.py
+@@ -12,9 +12,6 @@
+ setup_kwargs = dict()
+
+
+-storage_dirs = [ ('storage/whisper',[]), ('storage/lists',[]),
+- ('storage/log',[]), ('storage/rrd',[]) ]
+-conf_files = [ ('conf', glob('conf/*.example')) ]
+ #XXX Need a way to have these work for bdist_rpm but be left alone for everything else
+ #init_scripts = [ ('/etc/init.d', ['distro/redhat/init.d/carbon-cache',
+ # 'distro/redhat/init.d/carbon-relay',
+@@ -32,7 +29,6 @@
+ package_dir={'' : 'lib'},
+ scripts=glob('bin/*'),
+ package_data={ 'carbon' : ['*.xml'] },
+- data_files=storage_dirs + conf_files, # + init_scripts,
+ install_requires=['twisted', 'txamqp'],
+ **setup_kwargs
+ )
+