summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-07-20 19:07:01 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-07-20 19:07:01 +0000
commitd1288662dd1b09027e932f599472ee698a15ac6c (patch)
tree9ccc5f18e2ea54cf0ff2466db0649e6810207a04 /dev-python/IcePy
parentRemove generation 1 ebuild. (diff)
downloadgentoo-2-d1288662dd1b09027e932f599472ee698a15ac6c.tar.gz
gentoo-2-d1288662dd1b09027e932f599472ee698a15ac6c.tar.bz2
gentoo-2-d1288662dd1b09027e932f599472ee698a15ac6c.zip
version bump from Sam Jacobson (#185972)
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-python/IcePy')
-rw-r--r--dev-python/IcePy/ChangeLog10
-rw-r--r--dev-python/IcePy/IcePy-3.2.0.ebuild50
-rw-r--r--dev-python/IcePy/files/digest-IcePy-3.2.03
-rw-r--r--dev-python/IcePy/files/icepy-3.2.0-makefile.patch112
4 files changed, 173 insertions, 2 deletions
diff --git a/dev-python/IcePy/ChangeLog b/dev-python/IcePy/ChangeLog
index d5ab79423c32..671ab79f89fd 100644
--- a/dev-python/IcePy/ChangeLog
+++ b/dev-python/IcePy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/IcePy
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/IcePy/ChangeLog,v 1.3 2006/10/30 13:35:25 caleb Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/IcePy/ChangeLog,v 1.4 2007/07/20 19:07:01 caleb Exp $
+
+*IcePy-3.2.0 (20 Jul 2007)
+
+ 20 Jul 2007; Caleb Tennis <caleb@gentoo.org>
+ +files/icepy-3.2.0-makefile.patch, +IcePy-3.2.0.ebuild:
+ version bump from Sam Jacobson (#185972)
30 Oct 2006; Caleb Tennis <caleb@gentoo.org> IcePy-3.1.0.ebuild,
IcePy-3.1.1.ebuild:
diff --git a/dev-python/IcePy/IcePy-3.2.0.ebuild b/dev-python/IcePy/IcePy-3.2.0.ebuild
new file mode 100644
index 000000000000..355a60ef8a2f
--- /dev/null
+++ b/dev-python/IcePy/IcePy-3.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/IcePy/IcePy-3.2.0.ebuild,v 1.1 2007/07/20 19:07:01 caleb Exp $
+
+inherit eutils python
+
+DESCRIPTION="ICE middleware C++ bindings"
+HOMEPAGE="http://www.zeroc.com/index.html"
+SRC_URI="http://www.zeroc.com/download/Ice/3.2/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="test debug"
+
+DEPEND="=dev-cpp/Ice-3.2*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch ${FILESDIR}/icepy-${PV}-makefile.patch
+
+ if use amd64; then
+ sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
+ || die "Failed to set lib64 directory"
+ fi
+
+ if ! use debug; then
+ sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
+ ${S}/config/Make.rules || die "Failed to remove debug"
+ fi
+
+ sed -i -e \
+ "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
+ ${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
+}
+
+src_compile() {
+ cd ${S}
+ make || die "Died during make"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install Failed!"
+}
+
+src_test() {
+ ICE_HOME=/usr/share/Ice make test || die "Test failed"
+}
diff --git a/dev-python/IcePy/files/digest-IcePy-3.2.0 b/dev-python/IcePy/files/digest-IcePy-3.2.0
new file mode 100644
index 000000000000..a2c74e03bf9a
--- /dev/null
+++ b/dev-python/IcePy/files/digest-IcePy-3.2.0
@@ -0,0 +1,3 @@
+MD5 e3ccb5040449c73c5da380b62fefa7cd IcePy-3.2.0.tar.gz 169214
+RMD160 e61b0c79c019232099263831239dc0e44190c0b6 IcePy-3.2.0.tar.gz 169214
+SHA256 236cebc50b27552099fc2c1004baf4b908be04ce402c7a4541a17de115a76bf5 IcePy-3.2.0.tar.gz 169214
diff --git a/dev-python/IcePy/files/icepy-3.2.0-makefile.patch b/dev-python/IcePy/files/icepy-3.2.0-makefile.patch
new file mode 100644
index 000000000000..65827e45505e
--- /dev/null
+++ b/dev-python/IcePy/files/icepy-3.2.0-makefile.patch
@@ -0,0 +1,112 @@
+diff -rU5 IcePy-3.2.0-orig/Makefile IcePy-3.2.0/Makefile
+--- IcePy-3.2.0-orig/Makefile 2007-03-02 08:11:25.000000000 +1300
++++ IcePy-3.2.0/Makefile 2007-07-20 22:54:53.000000000 +1200
+@@ -38,10 +38,11 @@
+ echo "making $@ in $$subdir"; \
+ ( cd $$subdir && $(MAKE) $@ ) || exit 1; \
+ done
+
+ install::
+- $(call installdata,ICE_LICENSE,$(prefix))
+- $(call installdata,LICENSE,$(prefix))
++ mkdir -p $(install_slicedir)
++ $(call installdata,ICE_LICENSE,$(install_slicedir))
++ $(call installdata,LICENSE,$(install_slicedir))
+
+ test::
+ @python $(top_srcdir)/allTests.py
+diff -rU5 IcePy-3.2.0-orig/config/Make.rules IcePy-3.2.0/config/Make.rules
+--- IcePy-3.2.0-orig/config/Make.rules 2007-03-02 08:11:25.000000000 +1300
++++ IcePy-3.2.0/config/Make.rules 2007-07-20 22:46:28.000000000 +1200
+@@ -16,17 +16,17 @@
+ #
+ # Select an installation base directory. The directory will be created
+ # if it does not exist.
+ #
+
+-prefix = /opt/IcePy-$(VERSION)
++prefix = $(DESTDIR)/usr
+
+ #
+ # The "root directory" for runpath embedded in executables. Can be unset
+ # to avoid adding a runpath to Ice executables.
+ #
+-embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
++#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
+
+ #
+ # Define OPTIMIZE as yes if you want to build with optimization.
+ # Otherwise the Ice extension is built with debug information.
+ #
+@@ -99,12 +99,12 @@
+ VERSION_MINOR = 2
+ VERSION = 3.2.0
+ SOVERSION = 32
+ libdir = $(top_srcdir)/python
+
+-install_slicedir = $(prefix)/slice
+-install_pythondir = $(prefix)/python
++install_slicedir = $(prefix)/share/icepy-$(VERSION)/slice
++install_pythondir = $(prefix)/lib/$(PYTHON_VERSION)/site-packages
+
+ INSTALL = cp -fp
+ INSTALL_PROGRAM = ${INSTALL}
+ INSTALL_LIBRARY = ${INSTALL}
+ INSTALL_DATA = ${INSTALL}
+@@ -136,22 +136,22 @@
+ endif
+
+ ifneq ($(ICE_HOME),)
+ slicedir = $(ICE_HOME)/slice
+ else
+- slicedir = /usr/share/Ice-$(VERSION)/slice
++ slicedir = /usr/share/Ice/slice
+ endif
+
+-install_libdir = $(prefix)/python
++install_libdir = $(prefix)/lib
+
+-ifneq ($(embedded_runpath_prefix),)
+- ifeq ($(LP64),yes)
+- runpath_libdir := $(embedded_runpath_prefix)/lib$(lp64suffix)
+- else
+- runpath_libdir := $(embedded_runpath_prefix)/lib
+- endif
+-endif
++#ifneq ($(embedded_runpath_prefix),)
++# ifeq ($(LP64),yes)
++# runpath_libdir := $(embedded_runpath_prefix)/lib$(lp64suffix)
++# else
++# runpath_libdir := $(embedded_runpath_prefix)/lib
++# endif
++#endif
+
+ CPPFLAGS =
+ ICECPPFLAGS = -I$(slicedir)
+ SLICE2PYFLAGS = $(ICECPPFLAGS)
+
+@@ -198,11 +198,11 @@
+ installprogram = $(INSTALL_PROGRAM) $(1) $(2); \
+ chmod a+rx $(2)/$(notdir $(1))
+ endif
+
+ ifeq ($(mkdir),)
+- mkdir = mkdir $(1) ; \
++ mkdir = mkdir -p $(1) ; \
+ chmod a+rx $(1)
+ endif
+
+ #
+ # A Python extension library cannot have a "lib" prefix, so Python-specific
+diff -rU5 IcePy-3.2.0-orig/modules/IcePy/Makefile IcePy-3.2.0/modules/IcePy/Makefile
+--- IcePy-3.2.0-orig/modules/IcePy/Makefile 2007-01-09 08:25:09.000000000 +1300
++++ IcePy-3.2.0/modules/IcePy/Makefile 2007-07-20 23:03:25.000000000 +1200
+@@ -51,7 +51,8 @@
+ rm -f $@
+ ln -s $(SONAME) $@
+
+ install:: all
+ $(call installlib,$(install_libdir),$(libdir),$(LIBFILENAME),$(SONAME),$(LIBNAME))
++ ln -s $(install_libdir)/$(SONAME) $(install_pythondir)/$(LIBNAME)
+
+ include .depend