summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-08-12 01:55:10 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-08-12 01:55:10 +0000
commitf19f7842b9cc1818dcb4b3d52f2836f9208c8f5b (patch)
tree4e3b895327311432172c9b3cc4e58f20a2eb7e05 /dev-php
parentadd an rc build of php to try and fix #16825 (diff)
downloadgentoo-2-f19f7842b9cc1818dcb4b3d52f2836f9208c8f5b.tar.gz
gentoo-2-f19f7842b9cc1818dcb4b3d52f2836f9208c8f5b.tar.bz2
gentoo-2-f19f7842b9cc1818dcb4b3d52f2836f9208c8f5b.zip
add an rc build of php to try and fix #16825
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/ChangeLog7
-rw-r--r--dev-php/mod_php/Manifest4
-rw-r--r--dev-php/mod_php/files/digest-mod_php-4.3.3_rc32
-rw-r--r--dev-php/mod_php/mod_php-4.3.3_rc3.ebuild173
4 files changed, 183 insertions, 3 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index 91a282db1743..3bf944007bce 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/mod_php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.95 2003/08/11 07:46:07 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.96 2003/08/12 01:55:06 robbat2 Exp $
+
+*mod_php-4.3.3_rc3 (11 Aug 2003)
+
+ 11 Aug 2003; Robin H. Johnson <robbat2@gentoo.org> mod_php-4.3.3_rc3.ebuild:
+ add an rc build of php to try and fix #16825
11 Aug 2003; Robin H. Johnson <robbat2@gentoo.org> mod_php-4.3.2-r5.ebuild:
Make mod_php actually depend on apache if it isn't installed...
diff --git a/dev-php/mod_php/Manifest b/dev-php/mod_php/Manifest
index c7ce468e1f32..0982f4651d33 100644
--- a/dev-php/mod_php/Manifest
+++ b/dev-php/mod_php/Manifest
@@ -1,10 +1,10 @@
MD5 5dea99c418e697901136505efcefd39b mod_php-4.3.2.ebuild 3351
MD5 30e25e91644699efc5a97ac2f776b1bd mod_php-4.3.2-r5.ebuild 5073
-MD5 048465b2ac42c3d11df928deaf624ace mod_php-4.3.3_rc3.ebuild 5118
+MD5 5da4975d38a64cfed58d48061a0ebcad mod_php-4.3.3_rc3.ebuild 5092
MD5 4f9a379cbc9711222ee3ab765fb2fea2 mod_php-4.3.2-r2.ebuild 3657
MD5 4bc93aba5f4a7afb37bcf4bd4141f63b mod_php-4.3.2-r4.ebuild 4941
MD5 e26ab944bb819b5a7423acf58a47118b mod_php-4.3.2-r1.ebuild 2720
-MD5 fce80e2e4dfec1d65a50d2e5f803bfb2 ChangeLog 20266
+MD5 7d6ad5a947fdd90fdf42376898d8e9df ChangeLog 20427
MD5 435c911b2d32f4afb64abaf0de65b924 mod_php-4.3.2-r3.ebuild 4903
MD5 cceddd5c262e0ffef31d45b7da269851 files/mod_php.conf 148
MD5 c0f86a4fc233945f1db33bd39abe22ab files/70_mod_php.conf 1065
diff --git a/dev-php/mod_php/files/digest-mod_php-4.3.3_rc3 b/dev-php/mod_php/files/digest-mod_php-4.3.3_rc3
new file mode 100644
index 000000000000..d1f9a616375f
--- /dev/null
+++ b/dev-php/mod_php/files/digest-mod_php-4.3.3_rc3
@@ -0,0 +1,2 @@
+MD5 3dd83add4dbcd5233b32cffda7732b7b php-4.3.3RC3.tar.bz2 3709389
+MD5 912ff94309b762563d0542db5187315f php-4.3.2-fopen-url-secure.patch 416
diff --git a/dev-php/mod_php/mod_php-4.3.3_rc3.ebuild b/dev-php/mod_php/mod_php-4.3.3_rc3.ebuild
new file mode 100644
index 000000000000..f01d8657b85b
--- /dev/null
+++ b/dev-php/mod_php/mod_php-4.3.3_rc3.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.3_rc3.ebuild,v 1.1 2003/08/12 01:55:06 robbat2 Exp $
+
+IUSE="${IUSE} apache2"
+
+DESCRIPTION="Apache module for PHP"
+KEYWORDS="-* ~ppc"
+EXCLUDE_DB4_FIX=1
+EXCLUDE_PEAR_FIX=1
+SRC_URI_BASE="http://downloads.php.net/ilia"
+
+detectapache() {
+ local domsg=
+ [ -n "$1" ] && domsg=1
+ HAVE_APACHE1=
+ HAVE_APACHE2=
+ has_version '=net-www/apache-1*' && HAVE_APACHE1=1
+ has_version '=net-www/apache-2*' && HAVE_APACHE2=1
+
+ [ -n "${HAVE_APACHE1}" ] && APACHEVER=1
+ [ -n "${HAVE_APACHE2}" ] && APACHEVER=2
+ [ -n "${HAVE_APACHE1}" ] && [ -n "${HAVE_APACHE2}" ] && APACHEVER='both'
+
+ case "${APACHEVER}" in
+ 1) [ -n "${domsg}" ] && einfo 'Apache1 only detected' ;;
+ 2) [ -n "${domsg}" ] && einfo 'Apache2 only detected';;
+ both)
+ if [ "`use apache2`" ]; then
+ [ -n "${domsg}" ] && einfo "Multiple Apache versions detected, using Apache2 (USE=apache2)"
+ APACHEVER=2
+ else
+ [ -n "${domsg}" ] && einfo 'Multiple Apache versions detected, using Apache1 (USE=-apache2)'
+ APACHEVER=1
+ fi ;;
+ *) if [ -n "${domsg}" ]; then
+ MSG="Unknown Apache version!"; eerror $MSG ; die $MSG
+ else
+ APACHEVER=0
+ fi; ;;
+ esac
+}
+
+detectapache
+
+SLOT="${APACHEVER}"
+[ "${APACHEVER}" -eq '2' ] && USE_APACHE2='2' || USE_APACHE2=''
+
+PHPSAPI="apache${APACHEVER}"
+
+# BIG FAT WARNING!
+# the php eclass requires the PHPSAPI setting!
+# In this case the PHPSAPI setting is dependant on the detectapache function
+# above this point as well!
+inherit php eutils
+
+DEPEND="${DEPEND}
+ >=net-www/apache-1.3.26-r2
+ apache2? ( >=net-www/apache-2.0.43-r1 )"
+
+src_unpack() {
+ multiinstwarn
+ detectapache domsg
+ php_src_unpack
+}
+
+src_compile() {
+ #no readline on server SAPI
+ myconf="${myconf} --without-readline"
+
+ # Every Apache2 MPM EXCEPT prefork needs Zend Thread Safety
+ if [ -n "${USE_APACHE2}" ]; then
+ APACHE2_MPM="`apache2 -l |egrep 'worker|prechild|leader|threadpool|prefork'|xargs|cut -d. -f1`"
+ case "${APACHE2_MPM}" in
+ prefork) ;;
+ *) myconf="${myconf} --enable-experimental-zts" ;;
+ esac;
+ fi
+
+ # optional support for apache2
+ #&& myconf="${myconf} --with-apxs2=/usr/sbin/apxs2" \
+ #|| myconf="${myconf} --with-apxs=/usr/sbin/apxs"
+
+ #use apache2 \
+ myconf="${myconf} --with-apxs${USE_APACHE2}=/usr/sbin/apxs${USE_APACHE2}"
+
+ #php CGI stuff
+ #--enable-discard-path --enable-force-cgi-redirect
+
+ php_src_compile
+}
+
+
+src_install() {
+ php_src_install
+ einfo "Adding extra symlink to php.ini for Apache${USE_APACHE2}"
+ dodir /etc/apache${USE_APACHE2}/conf/
+ dodir ${PHPINIDIRECTORY}
+ dosym ${PHPINIDIRECTORY}/${PHPINIFILENAME} /etc/apache${USE_APACHE2}/conf/${PHPINIFILENAME}
+
+ einfo "Adding extra symlink to Apache${USE_APACHE2} extramodules for PHP"
+ dosym /usr/lib/apache${USE_APACHE2}-extramodules ${PHPINIDIRECTORY}/lib
+ exeinto /usr/lib/apache${USE_APACHE2}-extramodules
+ einfo "Installing mod_php shared object now"
+ doexe .libs/libphp4.so
+
+ if [ -n "${USE_APACHE2}" ] ; then
+ einfo "Installing a Apache2 config for PHP (70_mod_php.conf)"
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/70_mod_php.conf
+ else
+ einfo "Installing a Apache config for PHP (mod_php.conf)"
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_php.conf
+ dosym ${PHPINIDIRECTORY}/${PHPINIFILENAME} /etc/apache/conf/addon-modules/${PHPINIFILENAME}
+ fi
+}
+
+apache2msg() {
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PHP4\""
+ ewarn "This is a CHANGE from previous behavior, which was \"-D PHP\""
+ ewarn "This is for the upcoming PHP5 support. The ebuild will attempt"
+ ewarn "to make this update between PHP and PHP4 automatically"
+}
+
+multiinstwarn() {
+ ewarn "Due to some previous bloopers with PHP and slotting, you may have"
+ ewarn "multiple copies of mod_php installed. Please look at the autoclean"
+ ewarn "output at the end of the emerge and unmerge all but relevant"
+ ewarn "copies."
+}
+
+apache2fix() {
+ einfo "Attemping to update /etc/conf.d/apache2 automatically for the PHP/PHP4 change."
+ local oldfile="/etc/conf.d/apache2.old.`date +%Y%m%d%H%M%S`"
+ cp /etc/conf.d/apache2 ${oldfile}
+ sed -re 's,-D PHP\>,-D PHP4,g' ${oldfile} <${oldfile} >/etc/conf.d/apache2
+}
+
+
+pkg_preinst() {
+ multiinstwarn
+ [ "${APACHEVER}" -eq '2' ] && apache2fix
+ php_pkg_preinst
+}
+
+pkg_postinst() {
+ php_pkg_postinst
+ multiinstwarn
+ einfo "To have Apache run php programs, please do the following:"
+ if [ "`use apache2`" ] ; then
+ apache2msg
+ else
+ einfo "1. Execute the command:"
+ einfo " \"ebuild /var/db/pkg/dev-php/${PF}/${PF}.ebuild config\""
+ einfo "2. Edit /etc/conf.d/apache and add \"-D PHP4\""
+ einfo "That will include the php mime types in your configuration"
+ einfo "automagically and setup Apache to load php when it starts."
+ fi
+}
+
+pkg_config() {
+ multiinstwarn
+ if [ -n "${USE_APACHE2}" ] ; then
+ apache2msg
+ else
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libphp4.so mod_php4.c php4_module \
+ before=perl define=PHP4 addconf=conf/addon-modules/mod_php.conf
+ :;
+ fi
+}