summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-12-09 18:03:03 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-12-09 18:03:03 +0000
commit49b035e0d389d03a8270785e8ce2884c4da76427 (patch)
treef264a0f0f2c6cffe9264bbe92264fd72ea6a0b10 /dev-php
parentAdded LINGUAS="zh_TW". Fixed gcc-4.3 issue, bug #216759. (diff)
downloadgentoo-2-49b035e0d389d03a8270785e8ce2884c4da76427.tar.gz
gentoo-2-49b035e0d389d03a8270785e8ce2884c4da76427.tar.bz2
gentoo-2-49b035e0d389d03a8270785e8ce2884c4da76427.zip
Version bump, #250376
(Portage version: 2.2_rc17/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/smarty/ChangeLog8
-rw-r--r--dev-php/smarty/smarty-2.6.21.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-php/smarty/ChangeLog b/dev-php/smarty/ChangeLog
index 7999960ea6f6..01ee13fbc42b 100644
--- a/dev-php/smarty/ChangeLog
+++ b/dev-php/smarty/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/smarty
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.86 2008/11/29 17:40:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.87 2008/12/09 18:03:03 dertobi123 Exp $
+
+*smarty-2.6.21 (09 Dec 2008)
+
+ 09 Dec 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +smarty-2.6.21.ebuild:
+ Version bump, #250376
29 Nov 2008; Jeroen Roovers <jer@gentoo.org> smarty-2.6.20-r1.ebuild:
Stable for HPPA (bug #243856).
diff --git a/dev-php/smarty/smarty-2.6.21.ebuild b/dev-php/smarty/smarty-2.6.21.ebuild
new file mode 100644
index 000000000000..b82658db5992
--- /dev/null
+++ b/dev-php/smarty/smarty-2.6.21.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.21.ebuild,v 1.1 2008/12/09 18:03:03 dertobi123 Exp $
+
+inherit php-lib-r1 eutils
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+MY_P="Smarty-${PV}"
+
+DESCRIPTION="A template engine for PHP."
+HOMEPAGE="http://www.smarty.net/"
+SRC_URI="http://www.smarty.net/distributions/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+PDEPEND="doc? ( dev-php/smarty-docs )"
+
+S="${WORKDIR}/${MY_P}"
+
+need_php_by_category
+
+src_install() {
+ dodoc-php BUGS ChangeLog FAQ NEWS QUICK_START README RELEASE_NOTES TODO
+
+ php-lib-r1_src_install ./libs `find ./libs -type f -print | sed -e "s|./libs||g"`
+}
+
+pkg_postinst() {
+ elog "${PHP_LIB_NAME} has been installed in /usr/share/php/${PHP_LIB_NAME}/."
+ elog "To use it in your scripts, either"
+ elog "1. define('SMARTY_DIR', \"/usr/share/php/${PHP_LIB_NAME}/\") in your scripts, or"
+ elog "2. add '/usr/share/php/${PHP_LIB_NAME}/' to the 'include_path' variable in your"
+ elog "php.ini file under /etc/php/SAPI (where SAPI is one of apache2-php5,"
+ elog "cgi-php5 or cli-php5)."
+ elog
+ elog "If you're upgrading from a previous version make sure to clear out your"
+ elog "templates_c and cache directories as some include paths have changed!"
+}