summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2010-09-26 18:22:35 +0000
committerOle Markus With <olemarkus@gentoo.org>2010-09-26 18:22:35 +0000
commit8e8b7bfcafde2e488721f9a84ceb3c45fc1bc032 (patch)
treeaa64a368e6de5916f5c0e17a1f8c162e86695054 /dev-php5
parentDrop ruby19 to make this a stable candidate. (diff)
downloadgentoo-2-8e8b7bfcafde2e488721f9a84ceb3c45fc1bc032.tar.gz
gentoo-2-8e8b7bfcafde2e488721f9a84ceb3c45fc1bc032.tar.bz2
gentoo-2-8e8b7bfcafde2e488721f9a84ceb3c45fc1bc032.zip
Added dev-php5/pecl-haru (bug #249443)
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/pecl-haru/ChangeLog10
-rw-r--r--dev-php5/pecl-haru/metadata.xml9
-rw-r--r--dev-php5/pecl-haru/pecl-haru-1.0.0.ebuild34
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-php5/pecl-haru/ChangeLog b/dev-php5/pecl-haru/ChangeLog
new file mode 100644
index 000000000000..1db8eb1cd094
--- /dev/null
+++ b/dev-php5/pecl-haru/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-php5/pecl-haru
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-haru/ChangeLog,v 1.1 2010/09/26 18:22:35 olemarkus Exp $
+
+*pecl-haru-1.0.0 (26 Sep 2010)
+
+ 26 Sep 2010; <olemarkus@gentoo.org> +pecl-haru-1.0.0.ebuild,
+ +metadata.xml:
+ Added pecl-haru (bug #249443)
+
diff --git a/dev-php5/pecl-haru/metadata.xml b/dev-php5/pecl-haru/metadata.xml
new file mode 100644
index 000000000000..0c93320ef0b0
--- /dev/null
+++ b/dev-php5/pecl-haru/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <longdescription lang="en">These functions allow you to create PDF documents
+ using the Haru Free PDF Library.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/dev-php5/pecl-haru/pecl-haru-1.0.0.ebuild b/dev-php5/pecl-haru/pecl-haru-1.0.0.ebuild
new file mode 100644
index 000000000000..b3b0850c97a4
--- /dev/null
+++ b/dev-php5/pecl-haru/pecl-haru-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-haru/pecl-haru-1.0.0.ebuild,v 1.1 2010/09/26 18:22:35 olemarkus Exp $
+
+EAPI=3
+
+PHP_EXT_NAME="haru"
+
+inherit php-ext-pecl-r1
+
+DESCRIPTION="An interface to libharu, a PDF generator"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="png zlib"
+
+DEPEND="media-libs/libharu[png?,zlib?]"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_configure() {
+ true # php-ext-*-r1 doesn't really support EAPI=3
+}
+
+src_compile() {
+ # config.m4 is broken checking paths, so we need to override it
+ my_conf="--with-haru=/usr"
+ use png && my_conf+=" --with-png-dir=/usr"
+ use zlib && my_conf+=" --with-zlib-dir=/usr"
+
+ php-ext-source-r1_src_compile
+}