summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-07-07 13:35:46 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-07-07 13:35:46 +0000
commitc0f7912a8e11e0f597ee7f53cc8226ef2bf869df (patch)
treed63c00f5bae4f23cd9e194f21a73629d7a55c0f7 /dev-php5/xcache
parentversion bump to 1.2.1 including several bugfixes (some of them were segfaults... (diff)
downloadgentoo-2-c0f7912a8e11e0f597ee7f53cc8226ef2bf869df.tar.gz
gentoo-2-c0f7912a8e11e0f597ee7f53cc8226ef2bf869df.tar.bz2
gentoo-2-c0f7912a8e11e0f597ee7f53cc8226ef2bf869df.zip
version bump to 1.2.1 including several bugfixes (some of them were segfaults), see http://xcache.lighttpd.net/wiki/Release-1.2.1 for details (proxy-commit, thanks to hoffie)
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'dev-php5/xcache')
-rw-r--r--dev-php5/xcache/ChangeLog9
-rw-r--r--dev-php5/xcache/files/digest-xcache-1.2.13
-rw-r--r--dev-php5/xcache/xcache-1.2.1.ebuild75
3 files changed, 86 insertions, 1 deletions
diff --git a/dev-php5/xcache/ChangeLog b/dev-php5/xcache/ChangeLog
index 338d6a61c6cf..4e4e1d26b821 100644
--- a/dev-php5/xcache/ChangeLog
+++ b/dev-php5/xcache/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-php5/xcache
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/xcache/ChangeLog,v 1.7 2007/05/12 14:31:59 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/xcache/ChangeLog,v 1.8 2007/07/07 13:35:46 jokey Exp $
+
+*xcache-1.2.1 (07 Jul 2007)
+
+ 07 Jul 2007; Markus Ullmann <jokey@gentoo.org> +xcache-1.2.1.ebuild:
+ version bump to 1.2.1 including several bugfixes (some of them were
+ segfaults), see http://xcache.lighttpd.net/wiki/Release-1.2.1 for details
+ (proxy-commit, thanks to hoffie)
12 May 2007; Luca Longinotti <chtekk@gentoo.org> xcache-1.2.0.ebuild:
Fix require_php_sapi_from usage wrt apache1.
diff --git a/dev-php5/xcache/files/digest-xcache-1.2.1 b/dev-php5/xcache/files/digest-xcache-1.2.1
new file mode 100644
index 000000000000..87b99f0bd95e
--- /dev/null
+++ b/dev-php5/xcache/files/digest-xcache-1.2.1
@@ -0,0 +1,3 @@
+MD5 42133468871c573c397b8375dc8c19b6 xcache-1.2.1.tar.bz2 209708
+RMD160 f1b75ab5d3765d93c0ecfac4e23b3e2fbde3a7b8 xcache-1.2.1.tar.bz2 209708
+SHA256 67d56b7507005d4b88fda4de4876fe2ff6022c16360493486aabf94821f6ac67 xcache-1.2.1.tar.bz2 209708
diff --git a/dev-php5/xcache/xcache-1.2.1.ebuild b/dev-php5/xcache/xcache-1.2.1.ebuild
new file mode 100644
index 000000000000..ed74a1057aff
--- /dev/null
+++ b/dev-php5/xcache/xcache-1.2.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/xcache/xcache-1.2.1.ebuild,v 1.1 2007/07/07 13:35:46 jokey Exp $
+
+PHP_EXT_NAME="xcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+
+inherit php-ext-source-r1 confutils
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A fast and stable PHP opcode cacher"
+HOMEPAGE="http://xcache.lighttpd.net/"
+SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="!dev-php5/eaccelerator !dev-php5/pecl-apc"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+ require_php_sapi_from cgi apache2
+}
+
+src_compile() {
+ has_php
+
+ my_conf="--enable-xcache=shared \
+ --enable-xcache-constant \
+ --enable-xcache-optimizer \
+ --enable-xcache-coverager \
+ --enable-xcache-assembler \
+ --enable-xcache-encoder \
+ --enable-xcache-decoder"
+
+ enable_extension_with_built_with =${PHP_PKG} apache2 apxs2 /usr/sbin/apxs2 "optimisation for apache2"
+
+ php-ext-source-r1_src_compile
+}
+
+src_install() {
+ php-ext-source-r1_src_install
+ dodoc-php AUTHORS CHANGELOG INSTALL COPYING
+
+ php-ext-base-r1_addtoinifiles "auto_globals_jit" '"0"'
+ php-ext-base-r1_addtoinifiles "xcache.cacher" '"1"'
+ php-ext-base-r1_addtoinifiles "xcache.size" '"10M"'
+ php-ext-base-r1_addtoinifiles "xcache.count" '"2"'
+ php-ext-base-r1_addtoinifiles "xcache.slots" '"8k"'
+ php-ext-base-r1_addtoinifiles "xcache.var_size" '"0"'
+ php-ext-base-r1_addtoinifiles "xcache.var_count" '"1"'
+ php-ext-base-r1_addtoinifiles "xcache.readonly_protection" '"0"'
+ php-ext-base-r1_addtoinifiles "xcache.mmap_path" '"/dev/zero"'
+ php-ext-base-r1_addtoinifiles "xcache.stat" '"1"'
+ php-ext-base-r1_addtoinifiles "xcache.coverager" '"0"'
+ php-ext-base-r1_addtoinifiles "xcache.coveragedump_directory" '""'
+ php-ext-base-r1_addtoinifiles "xcache.admin.enable_auth" '"1"'
+
+ dodir "${PHP_EXT_SHARED_DIR}"
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins Decompiler.class.php
+ dodir "${PHP_EXT_SHARED_DIR}/admin"
+ insinto "${PHP_EXT_SHARED_DIR}/admin"
+ doins admin/*
+}
+
+pkg_postinst() {
+ elog "Decompiler.class.php and the admin/ directory shipped with this"
+ elog "release were installed into ${ROOT}usr/share/php5/xcache/."
+}