summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2007-12-04 11:07:07 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2007-12-04 11:07:07 +0000
commit2e93d1a1ec925acb835ad95f15ae41c95ac58279 (patch)
treeeaad948d376fe3699eea16519e959bf31dfc3dda /dev-php5/suhosin/suhosin-0.9.22.ebuild
parentalpha/ia64/sparc stable wrt security #200285 (diff)
downloadgentoo-2-2e93d1a1ec925acb835ad95f15ae41c95ac58279.tar.gz
gentoo-2-2e93d1a1ec925acb835ad95f15ae41c95ac58279.tar.bz2
gentoo-2-2e93d1a1ec925acb835ad95f15ae41c95ac58279.zip
bump to 0.9.22, bug #200921
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'dev-php5/suhosin/suhosin-0.9.22.ebuild')
-rw-r--r--dev-php5/suhosin/suhosin-0.9.22.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-php5/suhosin/suhosin-0.9.22.ebuild b/dev-php5/suhosin/suhosin-0.9.22.ebuild
new file mode 100644
index 000000000000..f2ae3d6774cc
--- /dev/null
+++ b/dev-php5/suhosin/suhosin-0.9.22.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/suhosin/suhosin-0.9.22.ebuild,v 1.1 2007/12/04 11:07:06 hoffie Exp $
+
+PHP_EXT_NAME="suhosin"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-source-r1
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="Suhosin is an advanced protection system for PHP installations."
+HOMEPAGE="http://www.suhosin.org/"
+SRC_URI="http://www.hardened-php.net/suhosin/_media/${P}.tgz"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+ require_php_with_use unicode
+}
+
+src_install() {
+ php-ext-source-r1_src_install
+ dodoc-php CREDITS
+
+ for inifile in ${PHPINIFILELIST} ; do
+ insinto "${inifile/${PHP_EXT_NAME}.ini/}"
+ insopts -m644
+ doins "suhosin.ini"
+ done
+}