summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-11-04 13:32:01 +0000
committerMatti Bickel <mabi@gentoo.org>2010-11-04 13:32:01 +0000
commitf279e274b682384415160781720eb5ac882b7e16 (patch)
tree1ced4fc164febe0dea1558f32936ff47f4408875 /dev-php5/pecl-htscanner
parentx86 stable, bug 341865 (diff)
downloadgentoo-2-f279e274b682384415160781720eb5ac882b7e16.tar.gz
gentoo-2-f279e274b682384415160781720eb5ac882b7e16.tar.bz2
gentoo-2-f279e274b682384415160781720eb5ac882b7e16.zip
add version that supports minor version slotting
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/pecl-htscanner')
-rw-r--r--dev-php5/pecl-htscanner/ChangeLog8
-rw-r--r--dev-php5/pecl-htscanner/pecl-htscanner-0.9.0-r1.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-php5/pecl-htscanner/ChangeLog b/dev-php5/pecl-htscanner/ChangeLog
index 0ee0d65ec7c9..ec6d06ac0a0a 100644
--- a/dev-php5/pecl-htscanner/ChangeLog
+++ b/dev-php5/pecl-htscanner/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/pecl-htscanner
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-htscanner/ChangeLog,v 1.9 2010/06/17 21:42:06 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-htscanner/ChangeLog,v 1.10 2010/11/04 13:32:01 mabi Exp $
+
+*pecl-htscanner-0.9.0-r1 (04 Nov 2010)
+
+ 04 Nov 2010; Matti Bickel <mabi@gentoo.org>
+ +pecl-htscanner-0.9.0-r1.ebuild:
+ add version that supports minor version slotting
17 Jun 2010; <mabi@gentoo.org> pecl-htscanner-0.9.0.ebuild:
restrict to <php-5.3, as the functionality is included in 5.3 and the
diff --git a/dev-php5/pecl-htscanner/pecl-htscanner-0.9.0-r1.ebuild b/dev-php5/pecl-htscanner/pecl-htscanner-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..d22f842ee020
--- /dev/null
+++ b/dev-php5/pecl-htscanner/pecl-htscanner-0.9.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-htscanner/pecl-htscanner-0.9.0-r1.ebuild,v 1.1 2010/11/04 13:32:01 mabi Exp $
+
+EAPI="3"
+
+PHP_EXT_NAME="htscanner"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+PHPSAPILIST="cgi"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Enables .htaccess options for php-scripts running as cgi."
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+# functionality is included in >=php-5.3
+USE_PHP="php5-2"
+
+DEPEND="dev-lang/php[cgi]"
+RDEPEND="${DEPEND}"
+
+my_conf="--enable-htscanner"
+
+src_install() {
+ php-ext-pecl-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "config_file" ".htaccess"
+ php-ext-source-r2_addtoinifiles "default_docroot" "/"
+ php-ext-source-r2_addtoinifiles "default_ttl" "300"
+ php-ext-source-r2_addtoinifiles "stop_on_error" "0"
+}