summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-06-12 20:20:40 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-06-12 20:20:40 +0000
commitdd0fdb75a8bffacd1295dee6fd056801f972c73c (patch)
treed7b028a5281173555fc9200260df51a713c21676 /dev-php5/ZendFramework
parentVersion bump (diff)
downloadgentoo-2-dd0fdb75a8bffacd1295dee6fd056801f972c73c.tar.gz
gentoo-2-dd0fdb75a8bffacd1295dee6fd056801f972c73c.tar.bz2
gentoo-2-dd0fdb75a8bffacd1295dee6fd056801f972c73c.zip
Version bump, #270880
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/ZendFramework')
-rw-r--r--dev-php5/ZendFramework/ChangeLog8
-rw-r--r--dev-php5/ZendFramework/ZendFramework-1.8.3.ebuild73
-rw-r--r--dev-php5/ZendFramework/metadata.xml1
3 files changed, 81 insertions, 1 deletions
diff --git a/dev-php5/ZendFramework/ChangeLog b/dev-php5/ZendFramework/ChangeLog
index f7c36234b2f4..6f8504e73855 100644
--- a/dev-php5/ZendFramework/ChangeLog
+++ b/dev-php5/ZendFramework/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/ZendFramework
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ChangeLog,v 1.53 2009/03/29 08:52:04 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ChangeLog,v 1.54 2009/06/12 20:20:40 dertobi123 Exp $
+
+*ZendFramework-1.8.3 (12 Jun 2009)
+
+ 12 Jun 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ +ZendFramework-1.8.3.ebuild:
+ Version bump, #270880
*ZendFramework-1.7.7 (29 Mar 2009)
diff --git a/dev-php5/ZendFramework/ZendFramework-1.8.3.ebuild b/dev-php5/ZendFramework/ZendFramework-1.8.3.ebuild
new file mode 100644
index 000000000000..ae7aeb5fa1d0
--- /dev/null
+++ b/dev-php5/ZendFramework/ZendFramework-1.8.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ZendFramework-1.8.3.ebuild,v 1.1 2009/06/12 20:20:40 dertobi123 Exp $
+
+PHP_LIB_NAME="Zend"
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="Zend Framework is a high quality and open source framework for developing Web Applications."
+HOMEPAGE="http://framework.zend.com/"
+SRC_URI="!minimal? ( http://framework.zend.com/releases/${P}/${P}.tar.gz )
+ minimal? ( http://framework.zend.com/releases/${P}/${P}-minimal.tar.gz )
+ doc? (
+ http://framework.zend.com/releases/${P}/${P}-apidoc.tar.gz
+ http://framework.zend.com/releases/${P}/${P}-manual-en.tar.gz )"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc examples minimal cli"
+
+DEPEND=""
+RDEPEND=""
+need_php_by_category
+
+src_unpack() {
+ if use minimal ; then
+ S="${WORKDIR}/${P}-minimal"
+ fi
+
+ unpack ${A}
+
+ cd "${S}"
+}
+
+src_install() {
+ if use cli ; then
+ insinto /usr/bin
+ doins bin/zf.php
+ dobin bin/zf.sh
+ dosym /usr/bin/zf.sh /usr/bin/zf
+ fi
+ php-lib-r1_src_install library/Zend $(cd library/Zend ; find . -type f -print)
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+
+ if ! use minimal ; then
+ doins -r demos
+ fi
+ fi
+
+ dodoc README.txt
+ if use doc ; then
+ dohtml -r documentation/*
+ fi
+}
+
+pkg_postinst() {
+ elog "For more info, please take a look at the manual at:"
+ elog "http://framework.zend.com/manual"
+ elog ""
+
+ if use minimal; then
+ elog "You have installed the minimal version of ZendFramework,"
+ elog "so the Dojo toolkit, demos and tests have not been installed."
+ else
+ elog "You have installed the full version of ZendFramework, which"
+ elog "includes the Dojo toolkit, demos and tests."
+ elog "To install ZendFramework without there, enable the"
+ elog "minimal USE flag."
+ fi
+}
diff --git a/dev-php5/ZendFramework/metadata.xml b/dev-php5/ZendFramework/metadata.xml
index b00da7befb7b..d240bb4ffcea 100644
--- a/dev-php5/ZendFramework/metadata.xml
+++ b/dev-php5/ZendFramework/metadata.xml
@@ -7,6 +7,7 @@
<name>Bjarke Istrup Pedersen</name>
</maintainer>
<use>
+ <flag name='cli'>Enables the CLI</flag>
<flag name='doc'>Installs the documentation</flag>
<flag name='examples'>Installs the examples</flag>
<flag name='minimal'>Installs the minimal version without Dojo toolkit, tests and demos</flag>