summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-21 17:18:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-21 17:18:45 +0000
commit0c00d0437002e27e87fd4ca1a380d4f59c559b85 (patch)
tree5900e9405f350672125a3a341a3f964c286ee43a /dev-php5/ZendFramework
parentold (diff)
downloadgentoo-2-0c00d0437002e27e87fd4ca1a380d4f59c559b85.tar.gz
gentoo-2-0c00d0437002e27e87fd4ca1a380d4f59c559b85.tar.bz2
gentoo-2-0c00d0437002e27e87fd4ca1a380d4f59c559b85.zip
Migrating to EAPI2 and usedeps to make users really happy. Fixes #285838
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/ZendFramework')
-rw-r--r--dev-php5/ZendFramework/ChangeLog8
-rw-r--r--dev-php5/ZendFramework/ZendFramework-1.9.2-r1.ebuild74
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-php5/ZendFramework/ChangeLog b/dev-php5/ZendFramework/ChangeLog
index 6559e88866fd..ddbfb6d2461f 100644
--- a/dev-php5/ZendFramework/ChangeLog
+++ b/dev-php5/ZendFramework/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/ZendFramework
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ChangeLog,v 1.58 2009/09/19 20:59:07 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ChangeLog,v 1.59 2009/09/21 17:18:45 patrick Exp $
+
+*ZendFramework-1.9.2-r1 (21 Sep 2009)
+
+ 21 Sep 2009; Patrick Lauer <patrick@gentoo.org>
+ +ZendFramework-1.9.2-r1.ebuild:
+ Migrating to EAPI2 and usedeps to make users really happy. Fixes #285838
*ZendFramework-1.9.2 (19 Sep 2009)
diff --git a/dev-php5/ZendFramework/ZendFramework-1.9.2-r1.ebuild b/dev-php5/ZendFramework/ZendFramework-1.9.2-r1.ebuild
new file mode 100644
index 000000000000..f4f905734281
--- /dev/null
+++ b/dev-php5/ZendFramework/ZendFramework-1.9.2-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ZendFramework-1.9.2-r1.ebuild,v 1.1 2009/09/21 17:18:45 patrick Exp $
+
+EAPI="2"
+
+PHP_LIB_NAME="Zend"
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="Zend Framework is a high quality and open source framework for developing Web Applications."
+HOMEPAGE="http://framework.zend.com/"
+SRC_URI="!minimal? ( http://framework.zend.com/releases/${P}/${P}.tar.gz )
+ minimal? ( http://framework.zend.com/releases/${P}/${P}-minimal.tar.gz )
+ doc? (
+ http://framework.zend.com/releases/${P}/${P}-apidoc.tar.gz
+ http://framework.zend.com/releases/${P}/${P}-manual-en.tar.gz )"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc examples minimal cli"
+
+DEPEND="cli? ( dev-lang/php[simplexml,tokenizer] )"
+RDEPEND="${DEPEND}"
+need_php_by_category
+
+src_prepare() {
+ if use minimal ; then
+ S="${WORKDIR}/${P}-minimal"
+ if use doc ; then
+ mv "${WORKDIR}/${P}/documentation" "${S}"
+ fi
+ fi
+}
+
+src_install() {
+ if use cli ; then
+ insinto /usr/bin
+ doins bin/zf.php
+ dobin bin/zf.sh
+ dosym /usr/bin/zf.sh /usr/bin/zf
+ fi
+ php-lib-r1_src_install library/Zend $(cd library/Zend ; find . -type f -print)
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+
+ if ! use minimal ; then
+ doins -r demos
+ fi
+ fi
+
+ dodoc README.txt
+ if use doc ; then
+ dohtml -r documentation/*
+ fi
+}
+
+pkg_postinst() {
+ elog "For more info, please take a look at the manual at:"
+ elog "http://framework.zend.com/manual"
+ elog ""
+
+ if use minimal; then
+ elog "You have installed the minimal version of ZendFramework,"
+ elog "so the Dojo toolkit, demos and tests have not been installed."
+ else
+ elog "You have installed the full version of ZendFramework, which"
+ elog "includes the Dojo toolkit, demos and tests."
+ elog "To install ZendFramework without there, enable the"
+ elog "minimal USE flag."
+ fi
+}