summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-08-08 23:56:18 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-08-08 23:56:18 +0000
commit3907790cac5d638dca29972d2df1337a90aa7098 (patch)
tree79014465ebef14f1a3e28ac1af1ecc402fbde0cb /dev-php/mod_php
parentmakecheck fails with sandbox enabled, so i've made the ebuilds die right away... (diff)
downloadgentoo-2-3907790cac5d638dca29972d2df1337a90aa7098.tar.gz
gentoo-2-3907790cac5d638dca29972d2df1337a90aa7098.tar.bz2
gentoo-2-3907790cac5d638dca29972d2df1337a90aa7098.zip
bug #59755.
Diffstat (limited to 'dev-php/mod_php')
-rw-r--r--dev-php/mod_php/ChangeLog6
-rw-r--r--dev-php/mod_php/files/digest-mod_php-5.0.0-r11
-rw-r--r--dev-php/mod_php/files/php-5.0.0-httpauthfix.patch20
-rw-r--r--dev-php/mod_php/mod_php-5.0.0-r1.ebuild139
4 files changed, 165 insertions, 1 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index c1cc24976c5f..c4451b56b6a8 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/mod_php
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.172 2004/08/06 03:19:00 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.173 2004/08/08 23:56:18 robbat2 Exp $
+
+ 08 Aug 2004; Robin H. Johnson <robbat2@gentoo.org>
+ +files/php-5.0.0-httpauthfix.patch:
+ bug #59755.
05 Aug 2004; Robin H. Johnson <robbat2@gentoo.org>
-files/mod_php-4.3.4-r3.diff, -mod_php-4.3.4-r4.ebuild,
diff --git a/dev-php/mod_php/files/digest-mod_php-5.0.0-r1 b/dev-php/mod_php/files/digest-mod_php-5.0.0-r1
new file mode 100644
index 000000000000..6c4e3a2e19be
--- /dev/null
+++ b/dev-php/mod_php/files/digest-mod_php-5.0.0-r1
@@ -0,0 +1 @@
+MD5 562b7ad1e903248bbe77884cb904b8b7 php-5.0.0.tar.bz2 4554054
diff --git a/dev-php/mod_php/files/php-5.0.0-httpauthfix.patch b/dev-php/mod_php/files/php-5.0.0-httpauthfix.patch
new file mode 100644
index 000000000000..f608ec317fa1
--- /dev/null
+++ b/dev-php/mod_php/files/php-5.0.0-httpauthfix.patch
@@ -0,0 +1,20 @@
+--- php-5.0.0/sapi/apache/mod_php5.c 2004-07-10 09:46:09.000000000 +0200
++++ php-5.0.0.1/sapi/apache/mod_php5.c 2004-08-08 11:32:52.824203512 +0200
+@@ -17,7 +17,7 @@
+ | PHP 4.0 patches by Zeev Suraski <zeev@zend.com> |
+ +----------------------------------------------------------------------+
+ */
+-/* $Id: php-5.0.0-httpauthfix.patch,v 1.1 2004/08/08 23:56:18 robbat2 Exp $ */
++/* $Id: php-5.0.0-httpauthfix.patch,v 1.1 2004/08/08 23:56:18 robbat2 Exp $ */
+
+ #include "php_apache_http.h"
+ #include "http_conf_globals.h"
+@@ -485,7 +485,7 @@
+ tmp = uudecode(r->pool, authorization);
+ SG(request_info).auth_user = NULL;
+ tmp_user = getword_nulls_nc(r->pool, &tmp, ':');
+- if (SG(request_info).auth_user) {
++ if (tmp_user) {
+ r->connection->user = pstrdup(r->connection->pool, tmp_user);
+ r->connection->ap_auth_type = "Basic";
+ SG(request_info).auth_user = estrdup(tmp_user);
diff --git a/dev-php/mod_php/mod_php-5.0.0-r1.ebuild b/dev-php/mod_php/mod_php-5.0.0-r1.ebuild
new file mode 100644
index 000000000000..c973ab0cc853
--- /dev/null
+++ b/dev-php/mod_php/mod_php-5.0.0-r1.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-5.0.0-r1.ebuild,v 1.1 2004/08/08 23:56:18 robbat2 Exp $
+
+IUSE="${IUSE} apache2"
+
+KEYWORDS="-x86 -ppc -sparc -alpha -hppa -ia64 -amd64 -s390"
+PROVIDE="virtual/php-${PV}"
+
+detectapache() {
+ local domsg=
+ [ -n "$1" ] && domsg=1
+ HAVE_APACHE1=
+ HAVE_APACHE2=
+ has_version '=net-www/apache-1*' && HAVE_APACHE1=1
+ has_version '=net-www/apache-2*' && HAVE_APACHE2=1
+
+ [ -n "${HAVE_APACHE1}" ] && APACHEVER=1
+ [ -n "${HAVE_APACHE2}" ] && APACHEVER=2
+ [ -n "${HAVE_APACHE1}" ] && [ -n "${HAVE_APACHE2}" ] && APACHEVER='both'
+
+ case "${APACHEVER}" in
+ 1) [ -n "${domsg}" ] && einfo 'Apache1 only detected' ;;
+ 2) [ -n "${domsg}" ] && einfo 'Apache2 only detected';;
+ both)
+ if use apache2; then
+ [ -n "${domsg}" ] && einfo "Multiple Apache versions detected, using Apache2 (USE=apache2)"
+ APACHEVER=2
+ else
+ [ -n "${domsg}" ] && einfo 'Multiple Apache versions detected, using Apache1 (USE=-apache2)'
+ APACHEVER=1
+ fi ;;
+ *) if [ -n "${domsg}" ]; then
+ MSG="Unknown Apache version!"; eerror $MSG ; die $MSG
+ else
+ APACHEVER=0
+ fi; ;;
+ esac
+}
+
+detectapache
+
+SLOT="5${APACHEVER}"
+[ "${APACHEVER}" -eq '2' ] && USE_APACHE2='2' || USE_APACHE2=''
+
+PHPSAPI="apache${APACHEVER}"
+MY_P="php-${PV}"
+
+# BIG FAT WARNING!
+# the php eclass requires the PHPSAPI setting!
+# In this case the PHPSAPI setting is dependant on the detectapache function
+# above this point as well!
+inherit php5-sapi eutils
+
+DESCRIPTION="Apache module for PHP 5"
+
+DEPEND_EXTRA=">=net-www/apache-1.3.26-r2
+ apache2? ( >=net-www/apache-2.0.43-r1 )"
+DEPEND="${DEPEND} ${DEPEND_EXTRA}"
+RDEPEND="${RDEPEND} ${DEPEND_EXTRA}"
+IUSE="${IUSE} debug"
+
+# Add a 'return 0' as we DON'T want the return code checked
+pkg_setup() {
+ use debug && einfo "Installing in SLOT=${SLOT}"
+ return 0
+}
+
+src_unpack() {
+ detectapache domsg
+
+ php5-sapi_src_unpack
+}
+
+src_compile() {
+ # Every Apache2 MPM EXCEPT prefork needs Zend Thread Safety
+ if [ -n "${USE_APACHE2}" ]; then
+ APACHE2_MPM="`/usr/sbin/apache2 -l |egrep 'worker|perchild|leader|threadpool|prefork'|cut -d. -f1|sed -e 's/^[[:space:]]*//g;s/[[:space:]]+/ /g;'`"
+ einfo "Apache2 MPM: ${APACHE2_MPM}"
+ case "${APACHE2_MPM}" in
+ *prefork*) ;;
+ *) my_conf="${my_conf} --enable-experimental-zts" ; ewarn "Enabling ZTS for Apache2 MPM" ;;
+ esac;
+ fi
+
+ #use apache2 \
+ my_conf="${my_conf} --with-apxs${USE_APACHE2}=/usr/sbin/apxs${USE_APACHE2}"
+
+ php5-sapi_src_compile
+}
+
+
+src_install() {
+ PHP_INSTALLTARGETS="install"
+ php5-sapi_src_install
+
+ einfo "Adding extra symlink to Apache${USE_APACHE2} extramodules for PHP"
+ dosym /usr/lib/apache${USE_APACHE2}-extramodules ${PHPINIDIRECTORY}/lib
+
+ if [ -n "${USE_APACHE2}" ] ; then
+ einfo "Installing a Apache2 config for PHP (70_mod_php5.conf)"
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/70_mod_php5.conf
+ else
+ einfo "Installing a Apache config for PHP (mod_php5.conf)"
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_php5.conf
+ dosym ${PHPINIDIRECTORY}/${PHPINIFILENAME} /etc/apache/conf/addon-modules/${PHPINIFILENAME}
+ fi
+}
+
+apache2msg() {
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PHP5\" to APACHE2_OPTS"
+}
+
+pkg_postinst() {
+ einfo "To have Apache run php programs, please do the following:"
+ if [ -n "${USE_APACHE2}" ]; then
+ apache2msg
+ else
+ einfo "1. Execute the command:"
+ einfo " \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "2. Edit /etc/conf.d/apache and add \"-D PHP5\" to APACHE_OPTS"
+ einfo "That will include the php mime types in your configuration"
+ einfo "automagically and setup Apache to load php when it starts."
+ fi
+}
+
+pkg_config() {
+ if [ -n "${USE_APACHE2}" ]; then
+ apache2msg
+ else
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libphp5.so mod_php5.c php5_module \
+ before=perl define=PHP5 addconf=conf/addon-modules/mod_php.conf
+ :;
+ fi
+}