summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-11-20 05:30:56 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-11-20 05:30:56 +0000
commitf55506c13367736ad1a19bc49edb7f709afb0551 (patch)
treec0f94cbc18fa8d4f2a1c96d99dddc51f2f2537a2 /dev-php/mod_php/mod_php-4.2.2-r1.ebuild
parentFixed DB dep in mysql-4.0.1. Fixes #10839 (diff)
downloadgentoo-2-f55506c13367736ad1a19bc49edb7f709afb0551.tar.gz
gentoo-2-f55506c13367736ad1a19bc49edb7f709afb0551.tar.bz2
gentoo-2-f55506c13367736ad1a19bc49edb7f709afb0551.zip
Tweaked deps
Diffstat (limited to 'dev-php/mod_php/mod_php-4.2.2-r1.ebuild')
-rw-r--r--dev-php/mod_php/mod_php-4.2.2-r1.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/dev-php/mod_php/mod_php-4.2.2-r1.ebuild b/dev-php/mod_php/mod_php-4.2.2-r1.ebuild
index 95713d0098e1..5114e32ede8f 100644
--- a/dev-php/mod_php/mod_php-4.2.2-r1.ebuild
+++ b/dev-php/mod_php/mod_php-4.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.2.2-r1.ebuild,v 1.16 2002/10/27 18:56:50 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.2.2-r1.ebuild,v 1.17 2002/11/20 05:30:56 rphillips Exp $
IUSE="freetype postgres tiff libwww nls jpeg ssl gd oci8 mysql X gdbm curl imap png xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb firebird pam"
@@ -52,7 +52,7 @@ DEPEND="
# readline? ( >=sys-libs/ncurses-5.1
# >=sys-libs/readline-4.1 )"
-RDEPEND="${DEPEND}
+RDEPEND="
qt? ( >=x11-libs/qt-2.3.0 )
xml? ( >=app-text/sablotron-0.95-r1 )"
@@ -111,13 +111,8 @@ src_compile() {
use ldap && myconf="${myconf} --with-ldap"
use firebird && myconf="${myconf} --with-interbase=/opt/interbase"
use freetype && myconf="${myconf} --with-ttf --with-t1lib"
-
- # rphillips - should fix #2708
- if [ "`use pdflib`" ] ; then
- myconf="${myconf} --with-pdflib=/usr"
- else
- use gd && myconf="${myconf} --with-gd"
- fi
+ use pdflib && myconf="${myconf} --with-pdflib=/usr"
+ use gd && myconf="${myconf} --with-gd"
use png && myconf="${myconf} --with-png-dir=/usr"
use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
use tiff && myconf="${myconf} --with-tiff-dir=/usr"