summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-01-11 03:32:17 +0000
committerBrian Evans <grknight@gentoo.org>2015-01-11 03:32:17 +0000
commit473801933f5ff8bbac0f3a24ab62d3dfd23a49f3 (patch)
treea1858bcb1a3aa497d57e140bd005cca33ecbd306 /dev-php/igbinary
parentDrop old (diff)
downloadgentoo-2-473801933f5ff8bbac0f3a24ab62d3dfd23a49f3.tar.gz
gentoo-2-473801933f5ff8bbac0f3a24ab62d3dfd23a49f3.tar.bz2
gentoo-2-473801933f5ff8bbac0f3a24ab62d3dfd23a49f3.zip
Restore igbinary version which would break pecl-memcached otherwise
(Portage version: 2.2.15/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 67C78E1D)
Diffstat (limited to 'dev-php/igbinary')
-rw-r--r--dev-php/igbinary/ChangeLog7
-rw-r--r--dev-php/igbinary/igbinary-1.1.1-r2.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-php/igbinary/ChangeLog b/dev-php/igbinary/ChangeLog
index c33b4077d98d..0fa745e2e22a 100644
--- a/dev-php/igbinary/ChangeLog
+++ b/dev-php/igbinary/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/igbinary
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/igbinary/ChangeLog,v 1.15 2015/01/11 03:21:49 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/igbinary/ChangeLog,v 1.16 2015/01/11 03:32:17 grknight Exp $
+
+*igbinary-1.1.1-r2 (11 Jan 2015)
+
+ 11 Jan 2015; Brian Evans <grknight@gentoo.org> +igbinary-1.1.1-r2.ebuild:
+ Restore igbinary version which would break pecl-memcached otherwise
11 Jan 2015; Brian Evans <grknight@gentoo.org> -igbinary-1.1.1-r2.ebuild:
Drop old
diff --git a/dev-php/igbinary/igbinary-1.1.1-r2.ebuild b/dev-php/igbinary/igbinary-1.1.1-r2.ebuild
new file mode 100644
index 000000000000..9d29e762b316
--- /dev/null
+++ b/dev-php/igbinary/igbinary-1.1.1-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/igbinary/igbinary-1.1.1-r2.ebuild,v 1.6 2015/01/11 03:32:17 grknight Exp $
+
+EAPI="5"
+PHP_EXT_NAME="igbinary"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+USE_PHP="php5-5 php5-3 php5-4"
+
+inherit php-ext-source-r2
+
+KEYWORDS="amd64 x86"
+
+DESCRIPTION="A fast drop in replacement for the standard PHP serialize"
+HOMEPAGE="http://opensource.dynamoid.com/"
+SRC_URI="http://opensource.dynamoid.com/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ epatch "${FILESDIR}/zts-fix.patch"
+ done
+ php-ext-source-r2_src_prepare
+}
+
+src_configure() {
+ my_conf="--enable-igbinary"
+ php-ext-source-r2_src_configure
+}
+
+src_test() {
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ NO_INTERACTION="yes" emake test || die "emake test failed for slot ${slot}"
+ done
+}