summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2011-12-14 22:29:48 +0000
committerMatti Bickel <mabi@gentoo.org>2011-12-14 22:29:48 +0000
commit8d6dbc3e96a0c44e82ab0d221491f5235de8858a (patch)
treee6e31c877b0a795f2238eb129da9fffdab3bba6b /dev-php/ffmpeg-php
parentMoving package from dev-php5 to dev-php category (bug #324665) (diff)
downloadgentoo-2-8d6dbc3e96a0c44e82ab0d221491f5235de8858a.tar.gz
gentoo-2-8d6dbc3e96a0c44e82ab0d221491f5235de8858a.tar.bz2
gentoo-2-8d6dbc3e96a0c44e82ab0d221491f5235de8858a.zip
Moving package from dev-php5 to dev-php category (bug #324665)
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-php/ffmpeg-php')
-rw-r--r--dev-php/ffmpeg-php/ChangeLog58
-rw-r--r--dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r1.ebuild39
-rw-r--r--dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-avutil50.patch31
-rw-r--r--dev-php/ffmpeg-php/metadata.xml5
4 files changed, 133 insertions, 0 deletions
diff --git a/dev-php/ffmpeg-php/ChangeLog b/dev-php/ffmpeg-php/ChangeLog
new file mode 100644
index 000000000000..1daaedcbe3c2
--- /dev/null
+++ b/dev-php/ffmpeg-php/ChangeLog
@@ -0,0 +1,58 @@
+# ChangeLog for dev-php5/ffmpeg-php
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/ffmpeg-php/ChangeLog,v 1.1 2011/12/14 22:29:48 mabi Exp $
+
+ 31 Mar 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ -ffmpeg-php-0.6.0.ebuild, ffmpeg-php-0.6.0-r1.ebuild:
+ Depend on virtual/ffmpeg instead of media-video/ffmpeg. Drop older
+ overshadowed ebuild.
+
+ 11 Jan 2011; Markus Meier <maekke@gentoo.org> ffmpeg-php-0.6.0-r1.ebuild:
+ x86 stable, bug #345891
+
+ 05 Jan 2011; Markos Chandras <hwoarang@gentoo.org>
+ ffmpeg-php-0.6.0-r1.ebuild:
+ Stable on amd64 wrt bug #345891
+
+ 04 Jan 2011; Ole Markus With <olemarkus@gentoo.org>
+ ffmpeg-php-0.6.0-r1.ebuild:
+ The test movie seems corrupt, so skipping tests
+
+*ffmpeg-php-0.6.0-r1 (03 Nov 2010)
+
+ 03 Nov 2010; Matti Bickel <mabi@gentoo.org> +ffmpeg-php-0.6.0-r1.ebuild:
+ create minor slotting compatible version
+
+ 22 Sep 2009; Alexis Ballier <aballier@gentoo.org> ffmpeg-php-0.6.0.ebuild,
+ +files/ffmpeg-php-0.6.0-avutil50.patch:
+ Fix build with latest ffmpeg, by Thomas Scheiblauer
+ <thomas.scheiblauer@hauptversammlung.at>, bug #283998
+
+*ffmpeg-php-0.6.0 (11 Dec 2008)
+
+ 11 Dec 2008; <ssuominen@gentoo.org> +ffmpeg-php-0.6.0.ebuild:
+ Version bump wrt #250636 and #242050, thanks to enyawix at yahoo.com and
+ b3hzat at gmail.com.
+
+*ffmpeg-php-0.5.3 (03 Jun 2008)
+
+ 03 Jun 2008; Luca Longinotti <chtekk@gentoo.org> -ffmpeg-php-0.5.1.ebuild,
+ +ffmpeg-php-0.5.3.ebuild:
+ Version bump.
+
+*ffmpeg-php-0.5.2.1 (09 May 2008)
+
+ 09 May 2008; Christian Hoffmann <hoffie@gentoo.org>
+ +ffmpeg-php-0.5.2.1.ebuild:
+ version bump to allow to compile against newer ffmpeg (bug 218097)
+
+*ffmpeg-php-0.5.1 (30 Aug 2007)
+
+ 30 Aug 2007; Markus Ullmann <jokey@gentoo.org> +metadata.xml,
+ +ffmpeg-php-0.5.1.ebuild:
+ Port from project overlay
+
+ 15 Aug 2007; Jakub Moc <jakub@gentoo.org> -ffmpeg-php-0.5.0.ebuild,
+ +ffmpeg-php-0.5.0.ebuild:
+ Version bump, check for gd support in PHP
+
diff --git a/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r1.ebuild b/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..3f6738a5a9e3
--- /dev/null
+++ b/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r1.ebuild,v 1.1 2011/12/14 22:29:48 mabi Exp $
+
+EAPI="3"
+
+PHP_EXT_NAME="ffmpeg"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-source-r2 eutils
+
+KEYWORDS="amd64 x86"
+
+DESCRIPTION="PHP extension that provides access to movie info."
+HOMEPAGE="http://sourceforge.net/projects/ffmpeg-php/"
+SRC_URI="mirror://sourceforge/ffmpeg-php/${P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/ffmpeg
+ || ( dev-lang/php[gd] dev-lang/php[gd-external] )"
+RDEPEND="${DEPEND}"
+
+# The test breaks with the test movie, but it the same code works fine with
+# other movies
+
+RESTRICT="test"
+
+DOCS="CREDITS ChangeLog EXPERIMENTAL TODO"
+
+src_prepare() {
+ for slot in $(php_get_slots) ; do
+ cd "${WORKDIR}/${slot}"
+ epatch "${FILESDIR}/${P}-avutil50.patch"
+ done
+ php-ext-source-r2_src_prepare
+}
diff --git a/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-avutil50.patch b/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-avutil50.patch
new file mode 100644
index 000000000000..070b5275d4d9
--- /dev/null
+++ b/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-avutil50.patch
@@ -0,0 +1,31 @@
+Index: ffmpeg-php-0.6.0/ffmpeg_frame.c
+===================================================================
+--- ffmpeg-php-0.6.0.orig/ffmpeg_frame.c
++++ ffmpeg-php-0.6.0/ffmpeg_frame.c
+@@ -333,7 +333,7 @@ FFMPEG_PHP_METHOD(ffmpeg_frame, toGDImag
+
+ GET_FRAME_RESOURCE(getThis(), ff_frame);
+
+- _php_convert_frame(ff_frame, PIX_FMT_RGBA32);
++ _php_convert_frame(ff_frame, PIX_FMT_RGB32);
+
+ return_value->value.lval = _php_get_gd_image(ff_frame->width,
+ ff_frame->height);
+@@ -418,7 +418,7 @@ FFMPEG_PHP_METHOD(ffmpeg_frame, ffmpeg_f
+
+ /* create a an av_frame and allocate space for it */
+ frame = avcodec_alloc_frame();
+- avpicture_alloc((AVPicture*)frame, PIX_FMT_RGBA32, width, height);
++ avpicture_alloc((AVPicture*)frame, PIX_FMT_RGB32, width, height);
+
+ /* copy the gd image to the av_frame */
+ _php_gd_image_to_avframe(gd_img, frame, width, height);
+@@ -429,7 +429,7 @@ FFMPEG_PHP_METHOD(ffmpeg_frame, ffmpeg_f
+ /* set the ffpmeg_frame's properties */
+ ff_frame->width = width;
+ ff_frame->height = height;
+- ff_frame->pixel_format = PIX_FMT_RGBA32;
++ ff_frame->pixel_format = PIX_FMT_RGB32;
+ break;
+ default:
+ zend_error(E_ERROR, "Invalid argument\n");
diff --git a/dev-php/ffmpeg-php/metadata.xml b/dev-php/ffmpeg-php/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/ffmpeg-php/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>