summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-03-27 21:48:26 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-03-27 21:48:26 +0000
commit423f7dca96e2a7262604ee5c64c9dc746407e013 (patch)
tree42656f17ac7521d487539167d25582d10767f88d /dev-perl
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-423f7dca96e2a7262604ee5c64c9dc746407e013.tar.gz
gentoo-2-423f7dca96e2a7262604ee5c64c9dc746407e013.tar.bz2
gentoo-2-423f7dca96e2a7262604ee5c64c9dc746407e013.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/SOAP-Lite/ChangeLog10
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-0.711.ebuild50
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-perl/SOAP-Lite/ChangeLog b/dev-perl/SOAP-Lite/ChangeLog
index 228798ae44d9..4a9171471017 100644
--- a/dev-perl/SOAP-Lite/ChangeLog
+++ b/dev-perl/SOAP-Lite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/SOAP-Lite
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.51 2009/12/24 19:34:44 tove Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.52 2010/03/27 21:48:26 robbat2 Exp $
+
+*SOAP-Lite-0.711 (27 Mar 2010)
+
+ 27 Mar 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +SOAP-Lite-0.711.ebuild:
+ Version bump via perl-bump experimental tool.
24 Dec 2009; Torsten Veller <tove@gentoo.org> -SOAP-Lite-0.710.08.ebuild:
Cleanup
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-0.711.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-0.711.ebuild
new file mode 100644
index 000000000000..b2c021bcaabf
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-0.711.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/SOAP-Lite-0.711.ebuild,v 1.1 2010/03/27 21:48:26 robbat2 Exp $
+
+MODULE_AUTHOR="MKUTTER"
+inherit perl-module eutils
+
+DESCRIPTION="Provides a simple and lightweight interface to the SOAP protocol (sic) both on client and server side."
+
+IUSE="jabber ssl"
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+myconf="${myconf} --noprompt"
+
+# TESTS ARE DISABLED ON PURPOSE
+# This module attempts to access an external website for validation
+# of the MIME::Parser - not only is that bad practice in general,
+# but in this particular case the external site isn't even valid anymore# -mpc
+# 24/10/04
+SRC_TEST="do"
+
+DEPEND="dev-perl/XML-Parser
+ dev-perl/libwww-perl
+ virtual/perl-libnet
+ dev-perl/MIME-Lite
+ virtual/perl-MIME-Base64
+ ssl? ( dev-perl/Crypt-SSLeay )
+ jabber? ( dev-perl/Net-Jabber )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ virtual/perl-IO-Compress
+ >=dev-perl/MIME-tools-5.413
+ virtual/perl-version
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # The author of this module put a dep for MIME::Parser 6.X - but the6.X
+ # release of MIME::Parser was a mistake during a change in maintainers on
+ # cpan. This patch alters the dependancy to the "real" stable version of
+ # MIME::Parser.
+ epatch "${FILESDIR}"/SOAP-Lite-0.710.08.patch
+}
+
+src_test() {
+ has_version '>=www-apache/mod_perl-2' && export MOD_PERL_API_VERSION=2
+ perl-module_src_test
+}