summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamien Krotkine <dams@gentoo.org>2002-12-07 15:35:14 +0000
committerDamien Krotkine <dams@gentoo.org>2002-12-07 15:35:14 +0000
commit324f5e60b3103870932868cdbd03c12a7fb528b7 (patch)
tree6d12d14cc29842ff967799f41135b6b17fcb34c6 /dev-perl
parentremove 2.1 (diff)
downloadgentoo-2-324f5e60b3103870932868cdbd03c12a7fb528b7.tar.gz
gentoo-2-324f5e60b3103870932868cdbd03c12a7fb528b7.tar.bz2
gentoo-2-324f5e60b3103870932868cdbd03c12a7fb528b7.zip
applied mcummings corrections, thank to him
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Common/Common-1.0.4.ebuild61
-rw-r--r--dev-perl/Common/files/Common-1.0.4.patch41
2 files changed, 55 insertions, 47 deletions
diff --git a/dev-perl/Common/Common-1.0.4.ebuild b/dev-perl/Common/Common-1.0.4.ebuild
index 6c1b1a76b8a2..f0064446372f 100644
--- a/dev-perl/Common/Common-1.0.4.ebuild
+++ b/dev-perl/Common/Common-1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 damien krotkine <dams@gentoo.org>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Common/Common-1.0.4.ebuild,v 1.1 2002/12/01 12:00:07 dams Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Common/Common-1.0.4.ebuild,v 1.2 2002/12/07 15:35:14 dams Exp $
ECVS_ANON="no"
ECVS_USER="anoncvs"
@@ -21,41 +21,48 @@ SLOT="0"
LICENSE="GPL"
KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
-#DEPEND="${DEPEND}
-# >=dev-lang/ocaml"
+DEPEND="dev-lang/ocaml
+ sys-devel/perl"
-#This patch may or may not be backwards compatible with perl-5.6.1
-#Add gaurd as necessary...
-
-#src_unpack() {
-# echo " ***** pouet $PWD";
-# echo "filesdir : ${FILESDIR}"
-# #unpack ${A}
-# echo " pwd : $PWD"
-# patch -p0 <${FILESDIR}/Common-1.0.4.patch || die
-#}
src_compile() {
cd ../../perl-MDK-Common;
- echo " pwd : $PWD"
- patch -p1 <${FILESDIR}/Common-1.0.4.patch || die
- echo "compile in ${PWD}";
- make clean;
- make
- #perl-module_src_prep;
- #perl-module_src_compile;
+ patch -p0 <${FILESDIR}/Common-1.0.4.patch || die
+ cp Makefile Makefile.bak
+ sed -e "s: /usr: ${D}/usr:" Makefile.bak > Makefile
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ INSTALLMAN2DIR=${D}/usr/share/man/man2 \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN4DIR=${D}/usr/share/man/man4 \
+ INSTALLMAN5DIR=${D}/usr/share/man/man5 \
+ INSTALLMAN6DIR=${D}/usr/share/man/man6 \
+ INSTALLMAN7DIR=${D}/usr/share/man/man7 \
+ INSTALLMAN8DIR=${D}/usr/share/man/man8 \
+ INSTALLSITEMAN1DIR=${D}/usr/share/man/man1 \
+ INSTALLSITEMAN2DIR=${D}/usr/share/man/man2 \
+ INSTALLSITEMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLSITEMAN4DIR=${D}/usr/share/man/man4 \
+ INSTALLSITEMAN5DIR=${D}/usr/share/man/man5 \
+ INSTALLSITEMAN6DIR=${D}/usr/share/man/man6 \
+ INSTALLSITEMAN7DIR=${D}/usr/share/man/man7 \
+ INSTALLSITEMAN8DIR=${D}/usr/share/man/man8 \
+ INSTALLSITEARCH=${D}/${SITE_ARCH} \
+ INSTALLSCRIPT=${D}/usr/bin
+
}
src_install() {
cd ../../perl-MDK-Common;
- echo "install in ${PWD}"
- make PREFIX=${D}/usr install
-}
+ make install
-src_prep() {
- SRC_PREP="yes"
- cd ../../perl-MDK-Common
- echo "prep in ${PWD}";
}
+
+#src_prep() {
+# SRC_PREP="yes"
+# cd soft/perl-MDK-Common
+#}
+
diff --git a/dev-perl/Common/files/Common-1.0.4.patch b/dev-perl/Common/files/Common-1.0.4.patch
index eab4b6a7c2d8..ca86a7e658d8 100644
--- a/dev-perl/Common/files/Common-1.0.4.patch
+++ b/dev-perl/Common/files/Common-1.0.4.patch
@@ -1,5 +1,5 @@
---- perl-Common/MDK/Common/DataStructure.pm.old 2002-11-27 21:55:08.000000000 +0100
-+++ perl-Common/MDK/Common/DataStructure.pm 2002-11-24 23:33:33.000000000 +0100
+--- MDK/Common/DataStructure.pm.old 2002-11-27 21:55:08.000000000 +0100
++++ MDK/Common/DataStructure.pm 2002-11-24 23:33:33.000000000 +0100
@@ -1,12 +1,12 @@
-package MDK::Common::DataStructure;
+package Common::DataStructure;
@@ -42,8 +42,8 @@
$l{$v};
}
---- perl-Common/MDK/Common/File.pm.old 2002-11-27 21:55:18.000000000 +0100
-+++ perl-Common/MDK/Common/File.pm 2002-11-24 23:33:33.000000000 +0100
+--- MDK/Common/File.pm.old 2002-11-27 21:55:18.000000000 +0100
++++ MDK/Common/File.pm 2002-11-24 23:33:33.000000000 +0100
@@ -1,12 +1,12 @@
-package MDK::Common::File;
+package Common::File;
@@ -69,8 +69,8 @@
=cut
---- perl-Common/MDK/Common/Func.pm.old 2002-11-27 21:55:29.000000000 +0100
-+++ perl-Common/MDK/Common/Func.pm 2002-11-24 23:33:33.000000000 +0100
+--- MDK/Common/Func.pm.old 2002-11-27 21:55:29.000000000 +0100
++++ MDK/Common/Func.pm 2002-11-24 23:33:33.000000000 +0100
@@ -1,12 +1,12 @@
-package MDK::Common::Func;
+package Common::Func;
@@ -161,8 +161,8 @@
$@ = $err;
if (my $v = &{$_}(\$err)) {
return $v;
---- perl-Common/MDK/Common/Globals.pm.old 2002-11-27 21:55:37.000000000 +0100
-+++ perl-Common/MDK/Common/Globals.pm 2002-11-24 23:33:33.000000000 +0100
+--- MDK/Common/Globals.pm.old 2002-11-27 21:55:37.000000000 +0100
++++ MDK/Common/Globals.pm 2002-11-24 23:33:33.000000000 +0100
@@ -1,4 +1,4 @@
-package MDK::Common::Globals;
+package Common::Globals;
@@ -222,8 +222,8 @@
$o->[0];
}
---- perl-Common/MDK/Common/Math.pm.old 2002-11-27 21:57:04.000000000 +0100
-+++ perl-Common/MDK/Common/Math.pm 2002-11-24 23:33:33.000000000 +0100
+--- MDK/Common/Math.pm.old 2002-11-27 21:57:04.000000000 +0100
++++ MDK/Common/Math.pm 2002-11-24 23:33:33.000000000 +0100
@@ -1,12 +1,12 @@
-package MDK::Common::Math;
+package Common::Math;
@@ -249,8 +249,8 @@
=cut
---- perl-Common/MDK/Common/String.pm.old 2002-11-27 21:57:12.000000000 +0100
-+++ perl-Common/MDK/Common/String.pm 2002-11-24 23:33:33.000000000 +0100
+--- MDK/Common/String.pm.old 2002-11-27 21:57:12.000000000 +0100
++++ MDK/Common/String.pm 2002-11-24 23:33:33.000000000 +0100
@@ -1,12 +1,12 @@
-package MDK::Common::String;
+package Common::String;
@@ -276,8 +276,8 @@
=cut
---- perl-Common/MDK/Common/System.pm.old 2002-11-27 21:57:18.000000000 +0100
-+++ perl-Common/MDK/Common/System.pm 2002-11-24 23:33:33.000000000 +0100
+--- MDK/Common/System.pm.old 2002-11-27 21:57:18.000000000 +0100
++++ MDK/Common/System.pm 2002-11-24 23:33:33.000000000 +0100
@@ -1,12 +1,12 @@
-package MDK::Common::System;
+package Common::System;
@@ -387,8 +387,8 @@
}
1;
---- perl-Common/MDK/Common/Various.pm.old 2002-11-27 21:57:24.000000000 +0100
-+++ perl-Common/MDK/Common/Various.pm 2002-11-24 23:33:33.000000000 +0100
+--- MDK/Common/Various.pm.old 2002-11-27 21:57:24.000000000 +0100
++++ MDK/Common/Various.pm 2002-11-24 23:33:33.000000000 +0100
@@ -1,12 +1,12 @@
-package MDK::Common::Various;
+package Common::Various;
@@ -414,8 +414,8 @@
=cut
---- perl-Common/MDK/Common.pm.pl.old 2002-11-27 21:54:56.000000000 +0100
-+++ perl-Common/MDK/Common.pm.pl 2002-11-24 23:04:40.000000000 +0100
+--- MDK/Common.pm.pl.old 2002-11-27 21:54:56.000000000 +0100
++++ MDK/Common.pm.pl 2002-11-24 23:04:40.000000000 +0100
@@ -1,40 +1,40 @@
@@ -504,8 +504,8 @@
$VERSION = "1.0.4";
---- perl-Common/Makefile.old 2002-11-27 21:24:38.000000000 +0100
-+++ perl-Common/Makefile 2002-11-27 21:51:53.000000000 +0100
+--- Makefile.old 2002-11-27 21:24:38.000000000 +0100
++++ Makefile 2002-11-27 21:51:53.000000000 +0100
@@ -1,9 +1,9 @@
-NAME = perl-MDK-Common
+NAME = perl-Common
@@ -534,3 +534,4 @@
rpm: update tar build commit
+