summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-09-15 14:21:11 +0000
committerPeter Volkov <pva@gentoo.org>2010-09-15 14:21:11 +0000
commitf18f3ff876141bc9e4ac9eae462a8718df8ded3e (patch)
treecd7d058c2388c1c3ba31e844eb7a603aa8c8a959 /dev-perl/SpeedyCGI
parentstable x86, bug 337125 (diff)
downloadgentoo-2-f18f3ff876141bc9e4ac9eae462a8718df8ded3e.tar.gz
gentoo-2-f18f3ff876141bc9e4ac9eae462a8718df8ded3e.tar.bz2
gentoo-2-f18f3ff876141bc9e4ac9eae462a8718df8ded3e.zip
Another patch from debian. Respect LDFLAGS, bug #335153, thank Diego E. 'Flameeyes' Pettenò for report. Drop old.
(Portage version: 2.1.9.5/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/SpeedyCGI')
-rw-r--r--dev-perl/SpeedyCGI/ChangeLog10
-rw-r--r--dev-perl/SpeedyCGI/SpeedyCGI-2.22-r2.ebuild44
-rw-r--r--dev-perl/SpeedyCGI/SpeedyCGI-2.22.ebuild24
-rw-r--r--dev-perl/SpeedyCGI/files/SpeedyCGI-2.22-big-socket-buffers.patch47
-rw-r--r--dev-perl/SpeedyCGI/files/SpeedyCGI-2.22-ldflags.patch13
5 files changed, 113 insertions, 25 deletions
diff --git a/dev-perl/SpeedyCGI/ChangeLog b/dev-perl/SpeedyCGI/ChangeLog
index 728c291a0db4..382cd7dd6149 100644
--- a/dev-perl/SpeedyCGI/ChangeLog
+++ b/dev-perl/SpeedyCGI/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-perl/SpeedyCGI
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SpeedyCGI/ChangeLog,v 1.9 2010/03/29 14:59:14 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SpeedyCGI/ChangeLog,v 1.10 2010/09/15 14:21:11 pva Exp $
+
+*SpeedyCGI-2.22-r2 (15 Sep 2010)
+
+ 15 Sep 2010; Peter Volkov <pva@gentoo.org> -SpeedyCGI-2.22.ebuild,
+ +SpeedyCGI-2.22-r2.ebuild, +files/SpeedyCGI-2.22-big-socket-buffers.patch,
+ +files/SpeedyCGI-2.22-ldflags.patch:
+ Another patch from debian. Respect LDFLAGS, bug #335153, thank Diego E.
+ 'Flameeyes' Pettenò for report. Drop old.
*SpeedyCGI-2.22-r1 (29 Mar 2010)
diff --git a/dev-perl/SpeedyCGI/SpeedyCGI-2.22-r2.ebuild b/dev-perl/SpeedyCGI/SpeedyCGI-2.22-r2.ebuild
new file mode 100644
index 000000000000..cc88866692c3
--- /dev/null
+++ b/dev-perl/SpeedyCGI/SpeedyCGI-2.22-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SpeedyCGI/SpeedyCGI-2.22-r2.ebuild,v 1.1 2010/09/15 14:21:11 pva Exp $
+
+EAPI="2"
+inherit perl-module
+
+DESCRIPTION="Speed up perl scripts by running them persistently"
+HOMEPAGE="http://daemoninc.com/SpeedyCGI/"
+SRC_URI="http://daemoninc.com/SpeedyCGI/CGI-${P}.tar.gz
+ http://oss.oetiker.ch/smokeping/pub/speedy-error.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/CGI-${P}
+
+PATCHES=( "${DISTDIR}/speedy-error.patch"
+"${FILESDIR}/${P}-makefile-manpage.patch"
+"${FILESDIR}/${P}-empty-param.patch"
+"${FILESDIR}/${P}-strerror.patch"
+"${FILESDIR}/${P}-apache-docs.patch"
+"${FILESDIR}/${P}-apache2.2.patch"
+"${FILESDIR}/${P}-strip-backend-libs.patch"
+"${FILESDIR}/${P}-test-timeout.patch"
+"${FILESDIR}/${P}-speedy_unsafe_putenv.patch"
+"${FILESDIR}/${P}-perl5.10.patch"
+"${FILESDIR}/${P}-perl_sys_init.patch"
+"${FILESDIR}/${P}-uninit-crash.patch"
+"${FILESDIR}/${P}-big-socket-buffers.patch"
+"${FILESDIR}/${P}-ldflags.patch"
+)
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+#src_configure() {
+# export myconf="OPTIMIZE=\"${LDFLAGS}\""
+# perl-module_src_configure
+#}
diff --git a/dev-perl/SpeedyCGI/SpeedyCGI-2.22.ebuild b/dev-perl/SpeedyCGI/SpeedyCGI-2.22.ebuild
deleted file mode 100644
index ee2d41d75f75..000000000000
--- a/dev-perl/SpeedyCGI/SpeedyCGI-2.22.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SpeedyCGI/SpeedyCGI-2.22.ebuild,v 1.5 2009/11/26 12:36:42 flameeyes Exp $
-
-inherit perl-module
-
-DESCRIPTION="Speed up perl scripts by running them persistently"
-HOMEPAGE="http://daemoninc.com/SpeedyCGI/"
-SRC_URI="http://daemoninc.com/SpeedyCGI/CGI-${P}.tar.gz
- http://oss.oetiker.ch/smokeping/pub/speedy-error.patch"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~sparc ~x86"
-IUSE=""
-
-DEPEND="dev-lang/perl"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/CGI-${P}
-
-PATCHES=( "${DISTDIR}/speedy-error.patch" )
-
-MAKEOPTS="${MAKEOPTS} -j1"
diff --git a/dev-perl/SpeedyCGI/files/SpeedyCGI-2.22-big-socket-buffers.patch b/dev-perl/SpeedyCGI/files/SpeedyCGI-2.22-big-socket-buffers.patch
new file mode 100644
index 000000000000..a67d9b6954b3
--- /dev/null
+++ b/dev-perl/SpeedyCGI/files/SpeedyCGI-2.22-big-socket-buffers.patch
@@ -0,0 +1,47 @@
+Author: Niko Tyni <ntyni@debian.org>
+Description: fix the detach test on systems with a large socket buffer size (#584344)
+--- speedy-cgi-perl.orig/speedy/t/detach.t
++++ speedy-cgi-perl/speedy/t/detach.t
+@@ -6,9 +6,22 @@
+
+ use strict;
+ use IO::File;
++use Socket;
+
+ my $smbuf = 8 * 1024;
+-my $lgbuf = 512 * 1024;
++my $lgbuf;
++
++# find out the size of the socket write buffer
++# see http://bugs.debian.org/584344
++my $s;
++if (socket($s, AF_UNIX, SOCK_STREAM, 0) &&
++ (my $packed_size = getsockopt($s, SOL_SOCKET, SO_SNDBUF))) {
++ $lgbuf = $smbuf + 2 * unpack("I", $packed_size);
++} else {
++ warn("socket() or getsockopt() failed: $!");
++}
++
++$lgbuf = 512 * 1024 if $lgbuf < 512 * 1024;
+ my $scr = 't/scripts/detach';
+
+ use vars qw(@open_files @pids %children);
+@@ -23,7 +36,7 @@
+ $| = 1; print ""; $| = 0;
+ my $child;
+ if (($child = open($fh, "-|")) == 0) {
+- open(F, "$ENV{SPEEDY} -- -B$sz $scr |");
++ open(F, "$ENV{SPEEDY} -- -B$sz $scr $lgbuf |");
+ print scalar <F>;
+ close(STDOUT);
+ sleep 60; # Simulate slow drain of output
+--- speedy-cgi-perl.orig/speedy/t/scripts/detach
++++ speedy-cgi-perl/speedy/t/scripts/detach
+@@ -1,3 +1,6 @@
+ $| = 1;
++# the data should not fit in the socket write buffer
++# see http://bugs.debian.org/584344
++my $size = shift || (512 * 1024);
+ print "$$\n";
+-print 'x' x (500*1024);
++print 'x' x int(500 / 512 * $size);
diff --git a/dev-perl/SpeedyCGI/files/SpeedyCGI-2.22-ldflags.patch b/dev-perl/SpeedyCGI/files/SpeedyCGI-2.22-ldflags.patch
new file mode 100644
index 000000000000..7eb8c9171fc1
--- /dev/null
+++ b/dev-perl/SpeedyCGI/files/SpeedyCGI-2.22-ldflags.patch
@@ -0,0 +1,13 @@
+=== modified file 'src/SpeedyMake.pl'
+--- src/SpeedyMake.pl 2010-08-30 20:08:42 +0000
++++ src/SpeedyMake.pl 2010-08-30 20:09:18 +0000
+@@ -328,7 +328,7 @@
+ sub remove_libs { undef }
+
+ sub get_ldopts {
+- $_ = "$LD_OPTS " . &ExtUtils::Embed::ldopts('-std');
++ $_ = "$LD_OPTS " . &ExtUtils::Embed::ldopts('-std') . " " . $ENV{LDFLAGS};
+ $EFENCE && s/$/ $EFENCE/;
+ return $_;
+ }
+