summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-08-16 17:38:10 +0000
committerTorsten Veller <tove@gentoo.org>2011-08-16 17:38:10 +0000
commitb39c4d3064b514d0f2b073419074284357fcdf6b (patch)
treebd0aa70e6fe89a42c2325f29878e03175317a431 /dev-perl/Email-Valid
parentDropped ppc keywords wrt #366765 (diff)
downloadgentoo-2-b39c4d3064b514d0f2b073419074284357fcdf6b.tar.gz
gentoo-2-b39c4d3064b514d0f2b073419074284357fcdf6b.tar.bz2
gentoo-2-b39c4d3064b514d0f2b073419074284357fcdf6b.zip
[bump] dev-perl/Email-Valid-0.185.0
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/Email-Valid')
-rw-r--r--dev-perl/Email-Valid/ChangeLog8
-rw-r--r--dev-perl/Email-Valid/Email-Valid-0.185.0.ebuild24
-rw-r--r--dev-perl/Email-Valid/files/0.185-disable-online-test.patch10
3 files changed, 41 insertions, 1 deletions
diff --git a/dev-perl/Email-Valid/ChangeLog b/dev-perl/Email-Valid/ChangeLog
index d8978c77012f..e0129ad96ba9 100644
--- a/dev-perl/Email-Valid/ChangeLog
+++ b/dev-perl/Email-Valid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Email-Valid
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Email-Valid/ChangeLog,v 1.49 2011/01/14 17:49:46 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Email-Valid/ChangeLog,v 1.50 2011/08/16 17:38:10 tove Exp $
+
+*Email-Valid-0.185.0 (16 Aug 2011)
+
+ 16 Aug 2011; Torsten Veller <tove@gentoo.org>
+ +files/0.185-disable-online-test.patch, +Email-Valid-0.185.0.ebuild:
+ Version bump
14 Jan 2011; Torsten Veller <tove@gentoo.org> -Email-Valid-0.179.ebuild,
-Email-Valid-0.181.ebuild:
diff --git a/dev-perl/Email-Valid/Email-Valid-0.185.0.ebuild b/dev-perl/Email-Valid/Email-Valid-0.185.0.ebuild
new file mode 100644
index 000000000000..c8a911ebacd4
--- /dev/null
+++ b/dev-perl/Email-Valid/Email-Valid-0.185.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Email-Valid/Email-Valid-0.185.0.ebuild,v 1.1 2011/08/16 17:38:10 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=RJBS
+MODULE_VERSION=0.185
+inherit perl-module
+
+DESCRIPTION="Check validity of Internet email addresses."
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/MailTools
+ dev-perl/Net-DNS"
+DEPEND="test? ( ${RDEPEND}
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+SRC_TEST="do"
+PATCHES=( "${FILESDIR}/0.185-disable-online-test.patch" )
diff --git a/dev-perl/Email-Valid/files/0.185-disable-online-test.patch b/dev-perl/Email-Valid/files/0.185-disable-online-test.patch
new file mode 100644
index 000000000000..6bcbf6d5df91
--- /dev/null
+++ b/dev-perl/Email-Valid/files/0.185-disable-online-test.patch
@@ -0,0 +1,10 @@
+--- a/t/valid.t
++++ b/t/valid.t
+@@ -85,6 +85,5 @@
+ );
+
+ SKIP: {
+- skip "your dns appears missing or failing to resolve", 2
+- unless eval { $v->address(-address=> 'devnull@pobox.com', -mxcheck => 1) };
++ skip "disabled online tests", 2;
+