summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-08-25 14:54:05 +0000
committerIan Delaney <idella4@gentoo.org>2013-08-25 14:54:05 +0000
commit41719502774f052cb35ad584fc535b9ca2ce2369 (patch)
treef1a396ba58570e6fe347cb1dbda6a2826b35ce7b /dev-perl/Eidetic
parentRevision bump: do not link to libelf statically, wrt bug #480940. Thanks to J... (diff)
downloadgentoo-2-41719502774f052cb35ad584fc535b9ca2ce2369.tar.gz
gentoo-2-41719502774f052cb35ad584fc535b9ca2ce2369.tar.bz2
gentoo-2-41719502774f052cb35ad584fc535b9ca2ce2369.zip
revbump, EAPI -> 5, add IUSE doc & upgrade install
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-perl/Eidetic')
-rw-r--r--dev-perl/Eidetic/ChangeLog10
-rw-r--r--dev-perl/Eidetic/Eidetic-2.003003-r1.ebuild80
2 files changed, 87 insertions, 3 deletions
diff --git a/dev-perl/Eidetic/ChangeLog b/dev-perl/Eidetic/ChangeLog
index a4f5d0e21099..3b3feb657e7f 100644
--- a/dev-perl/Eidetic/ChangeLog
+++ b/dev-perl/Eidetic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Eidetic
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Eidetic/ChangeLog,v 1.15 2012/06/23 20:21:02 tove Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Eidetic/ChangeLog,v 1.16 2013/08/25 14:54:05 idella4 Exp $
+
+*Eidetic-2.003003-r1 (25 Aug 2013)
+
+ 25 Aug 2013; Ian Delaney <idella4@gentoo.org> +Eidetic-2.003003-r1.ebuild:
+ revbump, EAPI -> 5, add IUSE doc & upgrade install
23 Jun 2012; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove wrong upstream info: Not on CPAN
@@ -56,4 +61,3 @@
+files/Eidetic-2.003003-destdir.patch, +files/Eidetic-2.003003-sql.patch,
+metadata.xml, +Eidetic-2.003003.ebuild:
Initial import into the tree to meet rackview depend.
-
diff --git a/dev-perl/Eidetic/Eidetic-2.003003-r1.ebuild b/dev-perl/Eidetic/Eidetic-2.003003-r1.ebuild
new file mode 100644
index 000000000000..ee29ff399294
--- /dev/null
+++ b/dev-perl/Eidetic/Eidetic-2.003003-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Eidetic/Eidetic-2.003003-r1.ebuild,v 1.1 2013/08/25 14:54:05 idella4 Exp $
+
+EAPI=5
+
+inherit perl-module webapp eutils
+
+DESCRIPTION="Templatized web-based database viewer, editor, indexer, etc"
+HOMEPAGE="http://eidetic.sourceforge.net/"
+SRC_URI="mirror://sourceforge/eidetic/${P}.tar.gz"
+
+LICENSE="Artistic"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc mysql auth"
+
+DEPEND="dev-lang/perl
+ >=dev-perl/Config-Simple-4.1
+ >=dev-perl/DBI-1.03
+ >=virtual/perl-File-Temp-0.12
+ >=virtual/perl-Digest-MD5-2.09
+ >=virtual/perl-CGI-2.56
+ virtual/perl-File-Spec
+ >=dev-perl/Mail-Sender-0.8
+ >=dev-perl/Sort-Tree-1.07
+ >=dev-perl/Template-Toolkit-2.08
+ dev-perl/Crypt-SmbHash
+ mysql? ( virtual/mysql )
+ auth? ( dev-perl/Apache-AuthTicket )"
+
+# This appears required
+MAKEOPTS="${MAKEOPTS} -j1"
+# Tests require invocation of a local mysql server
+
+PATCHES=( "${FILESDIR}"/${P}-destdir.patch \
+ "${FILESDIR}"/${P}-sql.patch )
+
+src_install() {
+ # explicit inherit function calls
+ perl-module_src_install
+ webapp_src_preinst
+
+ # install .cgi file
+ insinto ${MY_CGIBINDIR}
+ doins cgi-bin/eidetic.cgi
+
+ # install documentation
+ if use doc; then
+ docompress -x usr/share/doc/${PF}/txt
+ insinto usr/share/doc/${PF}/txt
+ doins doc/*
+ fi
+
+ # install db creation scripts
+ if use mysql
+ then
+ insinto /usr/share/${P}/sql
+ doins sql/*
+ fperms a+x /usr/share/${P}/sql/load_db.sh
+ fi
+
+ #webapp stuff
+ webapp_src_install
+}
+
+pkg_postinst() {
+ if use mysql; then
+ elog "The SQL scripts for ${PN} are located in /usr/share/${P}/sql."
+ elog "Use load_db.sh to create your initial database."
+ elog "Please note this must be ran as a user with database creation"
+ elog "priviliges."
+ elog ""
+ fi
+
+ if use auth; then
+ elog "The README file contains important information on setting up"
+ elog "cookie authorization with Apache-AuthTicket. Please be sure"
+ elog "to read it!"
+ fi
+}