summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-09-03 07:34:50 +0000
committerTorsten Veller <tove@gentoo.org>2010-09-03 07:34:50 +0000
commitf4d015101efb41d5a11512bfe242d4a018885f78 (patch)
treec231ce8aae09e36fce71ceea8d437179f7a9730b /dev-perl/DBD-Pg
parentVersion bump. (diff)
downloadgentoo-2-f4d015101efb41d5a11512bfe242d4a018885f78.tar.gz
gentoo-2-f4d015101efb41d5a11512bfe242d4a018885f78.tar.bz2
gentoo-2-f4d015101efb41d5a11512bfe242d4a018885f78.zip
Add lost prefix keywords. EAPI bump
(Portage version: 2.2_rc74_p2/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/DBD-Pg')
-rw-r--r--dev-perl/DBD-Pg/ChangeLog7
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-2.17.1-r1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-perl/DBD-Pg/ChangeLog b/dev-perl/DBD-Pg/ChangeLog
index f4b2a1e936e1..e00ffbe12d74 100644
--- a/dev-perl/DBD-Pg/ChangeLog
+++ b/dev-perl/DBD-Pg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/DBD-Pg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.77 2010/06/17 18:28:46 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.78 2010/09/03 07:34:50 tove Exp $
+
+*DBD-Pg-2.17.1-r1 (03 Sep 2010)
+
+ 03 Sep 2010; Torsten Veller <tove@gentoo.org> +DBD-Pg-2.17.1-r1.ebuild:
+ Add lost prefix keywords. EAPI bump
17 Jun 2010; Patrick Lauer <patrick@gentoo.org> DBD-Pg-2.15.1.ebuild,
DBD-Pg-2.16.0.ebuild, DBD-Pg-2.16.0-r1.ebuild, DBD-Pg-2.16.1.ebuild,
diff --git a/dev-perl/DBD-Pg/DBD-Pg-2.17.1-r1.ebuild b/dev-perl/DBD-Pg/DBD-Pg-2.17.1-r1.ebuild
new file mode 100644
index 000000000000..f7b5d3539015
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-2.17.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/DBD-Pg-2.17.1-r1.ebuild,v 1.1 2010/09/03 07:34:50 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=TURNSTEP
+inherit perl-module
+
+DESCRIPTION="The Perl DBD::Pg Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="virtual/perl-version
+ >=dev-perl/DBI-1.52
+ dev-db/postgresql-base"
+DEPEND="${RDEPEND}"
+
+# testcases require a local database with an
+# open password for the postgres user.
+SRC_TEST="skip"
+
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}