summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-10-09 00:06:22 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-10-09 00:06:22 +0000
commitbef18035450377e0ceab8f8db04a7eb63535aa6a (patch)
treecf7d3f6a4389e4298be3d9062ae8946ed7927698 /dev-ml
parentInvert gnupg dependencies, bug #328147. (diff)
downloadgentoo-2-bef18035450377e0ceab8f8db04a7eb63535aa6a.tar.gz
gentoo-2-bef18035450377e0ceab8f8db04a7eb63535aa6a.tar.bz2
gentoo-2-bef18035450377e0ceab8f8db04a7eb63535aa6a.zip
version bump
(Portage version: 2.2_rc91/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/cryptokit/ChangeLog9
-rw-r--r--dev-ml/cryptokit/cryptokit-1.4.ebuild66
2 files changed, 73 insertions, 2 deletions
diff --git a/dev-ml/cryptokit/ChangeLog b/dev-ml/cryptokit/ChangeLog
index 89869696aebe..46657073b81f 100644
--- a/dev-ml/cryptokit/ChangeLog
+++ b/dev-ml/cryptokit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/cryptokit
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/cryptokit/ChangeLog,v 1.4 2009/09/28 16:47:43 betelgeuse Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cryptokit/ChangeLog,v 1.5 2010/10/09 00:06:22 aballier Exp $
+
+*cryptokit-1.4 (09 Oct 2010)
+
+ 09 Oct 2010; Alexis Ballier <aballier@gentoo.org> +cryptokit-1.4.ebuild:
+ version bump
28 Sep 2009; Petteri Räty <betelgeuse@gentoo.org> cryptokit-1.3.ebuild:
Migrate to EAPI 2 in order to nuke built_with_use.
diff --git a/dev-ml/cryptokit/cryptokit-1.4.ebuild b/dev-ml/cryptokit/cryptokit-1.4.ebuild
new file mode 100644
index 000000000000..1be6fd9ee800
--- /dev/null
+++ b/dev-ml/cryptokit/cryptokit-1.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cryptokit/cryptokit-1.4.ebuild,v 1.1 2010/10/09 00:06:22 aballier Exp $
+
+EAPI="2"
+
+inherit findlib multilib
+
+DESCRIPTION="Cryptographic primitives library for Objective Caml"
+HOMEPAGE="http://forge.ocamlcore.org/projects/cryptokit/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/460/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="debug doc +ocamlopt zlib"
+
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ zlib? ( >=sys-libs/zlib-1.1 )"
+RDEPEND="${DEPEND}"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(use_enable zlib) \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_compile() {
+ emake || die
+ if use doc ; then
+ emake doc || die
+ fi
+}
+
+src_install() {
+ findlib_src_install
+ dodoc Changes README* AUTHORS* || die
+}
+
+pkg_postinst() {
+ elog ""
+ elog "This library uses the /dev/random device to generate "
+ elog "random data and RSA keys. The device should either be"
+ elog "built into the kernel or provided as a module. An"
+ elog "alternative is to use the Entropy Gathering Daemon"
+ elog "(http://egd.sourceforge.net). Please note that the"
+ elog "remainder of the library will still work even in the"
+ elog "absence of a one of these sources of randomness."
+ elog ""
+}
+
+src_test() {
+ echo ""
+ einfo "You must have either /dev/random or the Entropy Gathering"
+ einfo "Daemon (EGD) for this test to succeed!"
+ echo ""
+
+ emake test || die "emake test failed"
+}