summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-02 20:13:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-02 20:13:06 +0000
commit84c52d091bd99e9b3ff0d24df657002040a8fa13 (patch)
tree829e691a1d439f7f52a6b20832d8c282b5f18819 /dev-ml
parentdev-ml/lablgl ocamlopt useflag (diff)
downloadgentoo-2-84c52d091bd99e9b3ff0d24df657002040a8fa13.tar.gz
gentoo-2-84c52d091bd99e9b3ff0d24df657002040a8fa13.tar.bz2
gentoo-2-84c52d091bd99e9b3ff0d24df657002040a8fa13.zip
Add support to not build with ocamlopt
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lablgl/ChangeLog7
-rw-r--r--dev-ml/lablgl/lablgl-1.03.ebuild19
2 files changed, 20 insertions, 6 deletions
diff --git a/dev-ml/lablgl/ChangeLog b/dev-ml/lablgl/ChangeLog
index df8371499028..b0242987d9a8 100644
--- a/dev-ml/lablgl/ChangeLog
+++ b/dev-ml/lablgl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/lablgl
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.41 2007/12/11 10:12:47 aballier Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.42 2008/01/02 20:13:06 aballier Exp $
+
+ 02 Jan 2008; Alexis Ballier <aballier@gentoo.org> lablgl-1.03.ebuild:
+ Add support to not build with ocamlopt
*lablgl-1.03 (11 Dec 2007)
diff --git a/dev-ml/lablgl/lablgl-1.03.ebuild b/dev-ml/lablgl/lablgl-1.03.ebuild
index 8bf3327732cf..eaf71215facd 100644
--- a/dev-ml/lablgl/lablgl-1.03.ebuild
+++ b/dev-ml/lablgl/lablgl-1.03.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-1.03.ebuild,v 1.1 2007/12/11 10:12:47 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-1.03.ebuild,v 1.2 2008/01/02 20:13:06 aballier Exp $
inherit multilib eutils toolchain-funcs
-IUSE="doc"
+EAPI="1"
+
+IUSE="doc +ocamlopt"
DESCRIPTION="Objective CAML interface for OpenGL"
HOMEPAGE="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgl.html"
@@ -32,6 +34,13 @@ pkg_setup() {
eerror "Please recompile ocaml with tk useflag enabled."
die "Ocaml is missing tk support"
fi
+
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
}
src_compile() {
@@ -45,7 +54,9 @@ src_compile() {
echo 'INCLUDES = $(TKINCLUDES) $(GLINCLUDES) $(XINCLUDES)' >> Makefile.config
emake -j1 || die "failed to build"
- emake -j1 opt || die "failed to build opt"
+ if use ocamlopt; then
+ emake -j1 opt || die "failed to build opt"
+ fi
}
src_install () {